GPS RTK U-BLOX positioning

HELLO,
i am searching for a high precision GPS for my agricolture drone. It must follow a path (defined in mission planner) as precisely as possible.
I read that M8N GPS has a 2 meters error , that is too much… so i am searching for something better.
I found that on market there are RTK GPS, but i would not like to spend too much money for it.
My region is covered by a RTK GNSS network service (free), but i would like to understand better which hardware i need to connect to it.
This is the network:

http://www.spingnss.it/spiderweb/frmIndex.aspx

I would like to know which is the cheapest peace of hardware to connect to this network (i asked to them, they told me that i only need an RTK device).
In this case i need only the ‘rover’ module, or i need both the base and the rover?

Or perhaps it is better to buy a ‘base’ and a ‘rover’ and use my own network?

I am a newbie, so i would like to understand better which are the possible solutions…

Do you have any suggestion?

Let me know, thank you!!

Lodovico G.

You need an RTK receiver of F9P family (M8N is a waste of time and money). To connect to Spin3 GNSS service you need to have an onboard modem to feed RTCM to the receiver (harder) or you need to use Mission Planner as ground station and give internet access to the ground station to receive ntrip corrections and inject them over the telemetry link.

regards,
Corrado

Hello, thank you Corrado.
Let me understand better.
I found this device:


Then i need a suitable antenna (do you know which is the cheapest available, in the market?)
I have to mount the receiver (with antenna) on the multicopter, and to connect it to the flight controller.
Then i need a Laptop running Mission Planner and receiving NTRIP corrections from the SPIN3 GNSS service, via internet connection.
What i dont understand yet, is how the Mission planner can send the corrections to the receiver.
You told me, via telemetry link.
In my case, i use a Skydroid T10 , that provides both video and telemetry link, is it suitable to send the corrections to the receiver?
The onboard Skydroid T10 receiver , that receives the corrections, how can communicate them to the onboard Drotek receiver? It is needed a direct connection by some wire?
And to which pixhawk (2.4.8) port must be connected the Drotek receiver above?
I already own a M8N gps, i would like to put it as secondary gps, that can cover possible failures of the Drotek gps.
Is it possible? This setup can work?
Let us know ,
thank you!!

I do recommend the F9P but if you are on a budget and every penny counts then I have also had good results with this module for $110 USD: http://navspark.mybigcommerce.com/ns-hp-gn2-px1122r-multi-band-quad-gnss-rtk-breakout-board/ They have a multi frequency antenna for $50 but I have not used it (we have large vehicles and use large survey grade antennas)

thank you very much
but before buying something i need to understand better what i need .
I have a lenovo windows tablet that can run mission planner, a skydroid t10 radio and receiver, a pixhawk 2.4.8 flight controller, two telemetry modules 500mW, an M8N gps.
I wonder if buying that px1122r module i have all what i need, considering that my area is covered by a free real time RTK correction service.
I already have user and password, ip address and port to connect to the service.

I wonder if, instead, it is better to have two px1122r modules, one as base and one as rover…

every suggestion is appreciated…

i would like to add another question: why not put on the rover a 4G module (for example a light smartphone) to get directly the NTRIP correction data on the rover, without the need of the telemetry link?

i found this app ‘NTRIP Client’:

that can transmit correction to the receiver via bluetooth…

did you know it?