Servers by jDrones

GPS Problem with Matek F405 Wing

Really odd problem with GPS on a MatekF405 Wing. Arduplane 4.0.4 stable and latest version of Mission Planner.

Setup a ublox MN8 GPS, one I have used for years without problem, as normal and got a 3D Fix. A day later started up the plane and the GPS was present but no fix. The error on the HUD was “Bad GPS Signal Strength”. No amount of changing settings or restarts either hard or soft changed this nor did moving the plane around the yard.

Swapped the GPS on the Matek with a known working one and got a 3D Fix straight away. Sweet - fixed I thought - faulty GPS - however a few hours later when I started it up again - No Fix was back.

Eventually after much swearing and time I connected the first “faulty” GPS to a Pixhawk1 and got a 3D Fix straight up. I then put this GPS back on the Matek and it worked fine - 3D Fix in the same position in the yard as I setup the pixhawk. I turned off auto GPS config thinking the wrong config was being sent. However went I went to fly the next day at the open field I had No Fix and the same message on the screen.

Today I set log_disarmed to 1 and got two logs. The first one is with the GPS in No Fix. I then connected the same GPS to a Pixhawk with telemetry and saw on Mission Planner that it had an immediate 3D Fix. The plane with a Pixhawk is beside the plane with the Matek in my backyard.

The second log is where I reconnected the same GPS back on the Matek F405 and it is now fixed and has a 3D Fix straight away. Again I have not moved the plane.

Link to log files

Still having this problem. Bought a couple of Beltian BN-220 and these did not work either.

Finally installed iNAV on the board and the GPS worked perfectly. Will probably use this going forward.

I had similar problem. I contacted Matek support. They told me that this happens because some data was not erased during flashing. They advices to reflash the FC with “full chip erase”.
I did that and problem was solved.

1 Like

Thanks Dmitry - I will give it a go. Never even occurred me to ask Matek support.

Servers by jDrones