GPS over CAN not working with cube orange

Hi all
I have a strange problem with my cube orange.
My setup: cube orange with mRo u-Blox ZED-F9 connected via mRo KitCAN over CAN.
Issue: no GPS / satcount:0 (tested both CAN1 and CAN2)
Parameters for CAN:
GPS_AUTO_CONFIG 2 (auto for CAN)

If I look in SLCAN with the UAVCAN Inspector I see that the ZED-F9 has a fix and gives data (see picture)

bin file under link: - Envoi sécurisé et gratuit de gros fichiers

If I test the mRo u-Blox ZED-F9 connected via mRo KitCAN over CAN on a pixracer everything works perfect.

Many thanks for any help

Still no luck.
I tried to reset to default parameter
I tried the M9N and M8N on UART GPS1 port but still no sats in status. (the GPS are working on a pixracer)

Telemetrie and Compass is working.
It is hard to imagine that this is a hardware problem?
Any suggestion from Cube orange users?

to allow the CAN GPS to boot up and be ready when the Cube goes looking for it.
You might be able to reduce that delay to 3000 (3 seconds) but experiment once you have it working.


For some reason it tends not to use CAN GPS but to wait for GPS2

Many thanks for the responses.
I totally do not understand whats going on.
We switched laptops and everything was working!
I have to mention that I was connected by USB. Could the power on the USB have an impact?

1 Like