GPS : NOT FIX - Ardupilot 2.8

When I try to use my Ardupilot 2.8, I faced this problem
The gps is not fixed all the time. I tried to use it outdoor but no response
Any can help me to solve this problem?

Noting that when I went to INITIAL SETUP and try to connect with the gps I got this notification :

hi, wat kind of gps you use? one time i haved a similar problem, but it turned out that a tx cable was disconected off the gps, i soldered and solve the isue…
sometimes for some reason the cheap gps modules are bad… maybe thats the problem?

Actually I use this kit :
It contains the GPS.
Now, is there any way to inspect the TX and RX cables? I think they work fine.

And is there any other suggestions can i do? i tried to reverse TX and RX, and the result was : NO GPS

ok, i see,(just to say, if you bought on aliexpress you get it for the 1/2 of the price)
your magnetometer works ok?

you can chek it on the telemetry data mx my mz values chanque wen you move the external compasss…
same with latitude longitude…

for chek the cables, you ned to put out the screws of the gpsmodule plastic case, and see if they are good soldering on it,
to chek the cables are ok, you ned to chek the electric resistance of the wires, for that, if you dont have a multimeter you can use a DC Alcaline 1.5 v battery and a led… adn close the circuit wire by wire following the colors…

to use the external compas well you ned to remove the jumper next to the gps conector…

try to upload other firmware , for example upload ardurover and chek if persist the same problem…

and then upload again your firmware that i suspect that its copter… :slight_smile:

if the problem persist i dont kow how to healp you… maybe you ned to changue the gps module, i changued one time for a new and it works as you sse the gps-cpmpas was kind of broken…

if the problem persist you could try to configure it with ublox programs… but i not an expert on that…

no fix means it found the gps. are you testing outside in open sky?

Yes, that is right, if that GPS is new try open sky for at least half an hour.
Anyway, I don’t understand that picture you sent. Do you have a RTK GPS?