Servers by jDrones

GPS:No Fix....but there is a fix shown? (SOLVED by updating MIssion Planner to latest)


(Roger Ronald) #1

FC=F405 Wing
GPS=Hollybro Micro Mini (M8N)
Running ArduPlane 3.9.4.

I’ve tried UART3, UART5, and UART6. I’ve tried 115,200 and 38,400 Baud. Tried two different GPS units (both of the same type). All variations have the same behavior.

The artificial horizon window indicates that there is “GPS:No Fix” or “GPS:No GPS”. But, the plane is depicted in the correct position on the map display. Its movement within a small area (±10M) shows that the GPS is actively updating and that the flight controller is getting the data.

And…if I do the “arm” command, I will initially be rejected with the Mission Planner voice warning that “GPS NUM SATS = 5, NEED 6” …until I get the 6th satellite. At that point, the FC arms. The EKF status is good.

However, in the status display, I still see satcount=0 and gpsstatus2=0. There is a valid lat and long shown.

RR


(Peter Hall) #2

can you post your parameters file, thanks


(Roger Ronald) #3

Parameter file is available at: https://drive.google.com/open?id=1n-DBALFwf27Aq3MUwlY-DrTLmKZSLdyf


(mike kelly) #4

There is a big difference between GPS:no fix and GPS:noGPS. Nofix means you just have not gotten a good enough lock but the GPS is working and Ardupilot is receiving data. NOGPS means it is not connected or the baud rate is wrong.

Ardupilot will not arm until you have a minimum number of satellites and a minimum quality signal. Parameters that are changed in the parameter list. You just have to wait until it gets enough satellites. Remember the satellites are broadcasting a radio signal and they orbit the earth such that they “rise” and set constantly. Some become visible and others go down below the horizon.

The status display can display two GPS and you need to make sure you are looking at your primary not a non-existant secondary. Below they HUD the status of the actual GPS data can be seen and what GPS it is coming from.


(Roger Ronald) #5

I started with a fresh download of 3.9.4.

My display currently has “GPS: No GPS” displayed in the HUD, but the plane is displayed at its current position (it moves a tiny bit about once a second).

I realize that I need “n” sats to arm…I was describing the “GPS NUM SATS = 5, NEED 6” to show that the flight controller was clearly seeing some GPS satellites…and eventually saw enough to arm.

I have the GPS_TYPE parameter set to 1 (AUTO), The GPS_TYPE2 parameter is set to 0 (None).

I’m not sure about the status display you describe below the HUD. If it’s the tab labeled “status”, the data seems mixed at best (stat count of zero, but also showing a lat and long). The status below the map shows that too…lat and long and alt…but the text above shows hdop of 0.0 and Sats=0.

RR


(mike kelly) #6

You can not go by the position of the little aircraft on the map. There are other ways Ardupilot can determine direction etc.
It sounds like you don’t have a gps connected, meaning it is not at the right baud rate or the cable is wired wrong or it is defective.


(basti) #7

@RogerR as you already had a „noFix“ message on your telemetry screen, you most likely had it all set up correctly and then changed your serial port settings to less favorable values.
MatekF405-wing will look for GPS on SERIAL3 and 4 by default, with the default settings used for GPS being
BAUD = 38
PROTOCOL = 5

on a sidenote, the MatekF405-wing‘s 5V rail is not powered from USB by default, so you‘ll likely need a battery connected to have your serial ports‘ 5V pins provide power for periphereals.

in your parameters linked above you have BAUD set to 115 on your primary GPS port (SERIAL 3). your serial ports 4, 5 and 6 all have PROTOCOL set to -1 (=none) however.

i‘d suggest to go back to defaults on SERIAL3 and set
SERIAL3_BAUD = 38
SERIAL3_PROTOCOL = 5

then connect your GPS to your board‘s serial port 3 with a battery connected to your board, check you have RX / TX paired correctly, and look for that „GPS:noFix“ message. with good reception under open skies you‘ll likely get a good fix soon.

cheers, basti.


(Roger Ronald) #8

Mission Planner is telling me there is no GPS.

And yet, when I try to arm the plane too quickly, I hear that I only have 5 satellites. You can’t have 5 satellites w/o GPS! And if I wait a few minutes I can arm. This means the flight controller is seeing at least 6 satellites!

The GPS is powered (green LED) and eventually has a blinking blue light indicating that it has a valid fix. As stated in my first post, I have already tried Serial 3 as the GPS at 38 (38,400 baud) with the same results. The signal quality, as verified by oscilloscope, on the GPS TX line is great. I’ve also verified the RX of the GPS by using U-Center (I don’t see data from the FC to the GPS, but I assume that there’s no normal chit-chat in that direction once the GPS is programmed).

RR


(basti) #9

what does your MP’s message tab say when you connect? is there some lines like:

GPS 1: detected as u-blox at 115200 baud
u-blox 1 HW: 00080000 SW: ... ?


(mike kelly) #10

Under the HUD in mission Planner you can select and view the data coming from the GPS. Check and see if you are actually getting data. When I was talking about the quality of the GPS signal I was referring to the received radio signal.

When Mission Planner says no GPS it means it is not seeing GPS mavlink messages. THe fact that your map also shows hdop=0 and sats=0 also tells me Mission Planner does not see a GPS.

Those two data points contradict your " I hear that I only have 5 satellites" but it indicates something is abnormal. The port for the little F4’s is pretty new maybe there is a bug.


(Roger Ronald) #11

Here’s a set of messages starting at power up (which is at the bottom of these messages):

Throttle armed
Failsafe. Long event off: reason=3
Throttle failsafe off
EKF2 IMU0 is using GPS
PreArm: Radio failsafe on
PreArm: AHRS not healthy
EKF2 IMU0 Origin set to GPS
PreArm: Radio failsafe on
PreArm: GPS vert error 11.3m (needs < 11.3)
EKF2 IMU0 tilt alignment complete
EKF2 IMU0 initial yaw alignment complete
u-blox 1 HW: 00080000 SW: EXT CORE 3.01 (107900)
Flight mode = 11
Failsafe. Long event on: type=2/reason=3
MatekF405-Win 00370028 33374715 3835343
ChibiOS: ff603d11
ArduPlane V3.9.4 (7e37f2b6)
Flight mode = 1
Failsafe. Short event on: type=1/reason=3
Throttle failsafe on

The message on the HUD during all this is “GPS: No Fix”.

I think it took about 60 seconds to get it to arm…which is pretty darn quick for inside my house.

Here’s another run. I was hitting ARM about every 10 seconds:

Throttle armed
EKF2 IMU0 is using GPS
EKF2 IMU0 Origin set to GPS
PreArm: GPS HDOP 2.6 (needs 2.5)
PreArm: GPS HDOP 2.6 (needs 2.5)
PreArm: GPS HDOP 2.6 (needs 2.5)
PreArm: GPS HDOP 2.6 (needs 2.5)
PreArm: GPS HDOP 3.0 (needs 2.5)
PreArm: GPS HDOP 3.0 (needs 2.5)
PreArm: GPS HDOP 3.0 (needs 2.5)
PreArm: GPS numsats 5 (needs 6)
PreArm: GPS numsats 4 (needs 6)
PreArm: GPS numsats 4 (needs 6)
EKF2 IMU0 tilt alignment complete
EKF2 IMU0 initial yaw alignment complete
PreArm: Bad GPS Position
PreArm: EKF starting GPS checks
PreArm: Bad GPS Position
PreArm: EKF2 init failure: No GPS lock
u-blox 1 HW: 00080000 SW: EXT CORE 3.01 (107900)
MatekF405-Win 00370028 33374715 3835343
ChibiOS: ff603d11
ArduPlane V3.9.4 (7e37f2b6)

Again, the claim on the HUD is “GPS: No FIx”. At the bottom of the map, it shows 0 sats and a hdop of 100.


(Roger Ronald) #12

Mike,

Not sure where you’re talking about seeing the dat coming from the GPS. I can set lat and long (both look correct) to be displayed on the HUD along with GPS Status (=1) and hdop (=99.99).

I can also see lat and long, gps status, hdop, and sat count in the “status” tab. Again, lat and long look correct. hdop and sat count is wrong.

Pretty sure I can fly with the current situation, since the EKF is seeing the GPS…despite the erronous indications from the Mission Planner displays. But something in Arduplane 3.9.4 or Mission Planner seems wrong if the EKF says GPS is working and Mission Planner displays that it isn’t.


(Roger Ronald) #13

New data.

I pulled dataflash logs from yesterday.

I had an average of 16 sats during a two hour period (min=11, max=19). Pretty good for inside the house. In the second log (19 mins long), the log started with 6 sats (when it first armed, climbed to 13 after about 2 minutes, and stayed in the range from 13-15 the rest of the time.

GPS status was 4 (as good as it gets) the entire time in the long log. In the short one, it started at 3 and went to 4 about a minute in.

hdop was “1”(great) the entire time.

Here’s the short log showing the count and the status:

Short log is available at https://drive.google.com/open?id=1hm3xj6pA_6xToOt2zt6eqQvK3qS2G2XC


(mike kelly) #14

Under the HUD is a display with live data and you can right click and specify what want to see, I am not talking about the messages tab.
But your log certainly looks like you are getting GPS data. However I would be real careful because when the flight controller is flying, in any fc assisted mode, and it gets confused it could take your aircraft anywhere without asking you for permission:)


(Roger Ronald) #15

I did three flights yesterday. Used auto takeoff for this “re-maiden”. All worked great in FBWA and auto modes.

I suspect something is preventing the normal complement of GPS telemetry from being passed on serial0 (the usb port). I’ll see if I can connect a telemetry radio in order to determine if the lack of proper GPS status in Mission Planner occurs on the other UARTs too.

RR


(Roger Ronald) #16

Update. I added a SIK radio on the Telem1 port. It’s communicating with my PC over that link. USB is not connected. Still have the same problem…GPS is working fine, but Mission Planner indicates that it doesn’t have a fix and shows the wrong sat count (0) and hdop (100).
.

.

Notice that the HUD shows a lat and a long (as does the map view). But the HUD hdop is wrong, as is the map hdop and sat count. The map also shows position, including altitude. The HUD is showing “GPS:No Fix”, but it sometimes shows “GPS:No GPS”.


(WickedShell) #17

FWIW I’ve had that problem with MP recently and it was just a MP specific bug on showing the data, changing MP versions resolved it (or using other GCS’s which is what I normally do anyways). I don’t have the computer near me that had the problem though.


(Roger Ronald) #18

WickedShell

Thanks for your reply. This problem was caused by a version of MIssion Planner. I was running 1.3.52 and my problem was evidenced on two computers running this version…

For some reason, my MP was not trying to update. The buttons on the help screen to check for updates (and beta updates) didn’t work. I had to delete the old version and reinstall. Took a few tries, but eventually I succeeded.

The latest version of MP (1.3.62) works great and my problem is now solved. :smiling_face_with_three_hearts: Thanks again!

RR