Servers by jDrones

GPS NEO3 suddenly stopped working

Good morning everyone,
During our testing yesterday with the Neo3 GPS as position source, we had an odd situation that sadly we do not know how to reproduce. We had a drone flyable for days with this system after following the steps for configuring it. We never enabled the parameters for configuring it (SLCAN interface), and suddenly yesterday the GPS stopped working. It was not that the Arducopter did not detect the GPS, it was that suddenly it stopped detecting satellites. Curiously, what worked for us was to reflash the 4.1.0-beta3 firmware and upload exactly the same parameters; literally, we saved the parameters in a file before reflashing, and after that we upload them again.

The particular thing is that we had a couple of times exactly the same situation with a U-blox FP9 based GPS using the 4.0.7, and the solution was the same in some cases. In some other cases we needed to completely reset the GPS units using the Ucenter. My question, and I need to read the AP_GPS code, is if there is any kind of configuration or calibration that is performed only after a fresh re-flashing that never happens again. I think that can shred some light on what can be the issue.

@sbaccam,

I don’t have an explanation I’m afraid but I’ll ask around in the dev team.

By the way, it is normally not necessary to upload parameters to the board after upgrading the firmware. The flash for the software and the eeprom storage for the parameters are separate and we go to great lengths actually to properly upgrade parameters as required across versions.

1 Like

You are right with the EEPROM; we just tried it. Regarding the Neo GPS, it seems like a power sequence problem. When I connect it to the Pixhawk and pwer the Pixhawk cube Orange through the micro USB port, the buzzer on the GPS does not sound and the problems start; This the scenario when I power on the companion computer first ans it powers on the Pixhawk. When I connect first the battery and the DC/DC converter that powers the Pixhawk through POWER1 or POWER2 peripherals, the behavior is different.

1 Like

@sbaccam,

OK, thanks for the feedback. UBlox GPSs are known to not operate properly if they don’t receive sufficient power so this makes sense. We’ve seen this very clearly on the F9 RTK GPSs but it is likely true of all Ublox GPSs (and maybe those from other manufacturers too).

Can you remove the power wire from the USB cable to the companion computer so it’s not interfering with the pixhawks normal power1/power2 selection and functionality?

Good morning @xfacta ,

It is because a requirement that I have in that project where I require sometimes to be able to reflash the Firmware from the companion computer. What I am going to try is to set different power supplies with enable pins and set the power sequence correctly. This is the way it should be done from an electrical engineering standpoint.

Servers by jDrones