GPS Issue

One last thing to sort out. I have a Pixhawk (latest rev) installed on my QAV400. Got the rest of the PIDS tweaked today an it’s flying really nice! Next step was to install the 3DR GPS/Compass (Installed on mast). Got everything calibrated and back in the air.

When I hit loiter mode it very mildly twitched then locked in tight for a minute or so. Flipped back to Att, flew around then went back into loiter again. Same thing except it did a slight bank right and started to drift off on it’s own. I flipped back to Att and got it back. Tried it again, same thing. Shut everything down and did a restart. Still wouldn’t lock in. Then finally it did and locked into a nice steady hover for about 2 minutes, then over time yawed left and start to drift again, each time loosing altitude.


Thanks much!

Providing tlogs and/or data flash logs will greatly help to troubleshoot your issue.

Thank you, got it solved. After searching these forums for awhile I ran across a thread that pointed me in the right direction. I had the external GPS/compass selected in the setup w/180. Should have been just the Pixhawk and no 180.

Yes, you probably happened to point the copter north when it worked.

That’s exactly it, my back yard faces due north.