GPS Horz and Speed error after firmware upgrade

I have run into a problem that i can not solve or find much about.

This is the history of what i have done.

I had a pixhawk fitted to a quadcopter frame i used and it all worked perfectly, i moved the pixhawk flight control to a new platform and needed up change the firmware as the frame type was different, doing this upgraded the firmware to 3.3.2, unfortunatly i did not take not of the previous version.

I configured the flight control system as before and then the problem started.

since doing this i keep getting GPS Horz error of 5 and above and also GPS speed error.

It does not matter how many times i recalibrate the compass or accelorometers i still have this problem.

I have tried reasearching this but can find next to nothing regarding this issue hence getting onto this forum to see if it can shed some light onto this. This is the first issue i have had with the pixhawk, all other issues are documented or i have worked out.

What i do know is that it is not due to acc or compass calibration or part of the prearm checks, if you disable the prearm checks it still comes up with the same error.

Can someone please help me understand what causes this issue and how i can go about resolving this.
If i leave the platform for about an hour it will finally say it is ok to arm and take off but firstly this is not practical and it does not fly well at all, it oscillates a lot but this might be due to no tuning being done yet.

Is it due to the current firmware and if it is what one should i use.

Any questions please ask as this one has got me stumped at the moment.

Looking forward to any help on this.

Thanks for your time.

whats your SAT count and HDOP? are you doing this outside? mine does this usually if its inside building

I am have the same problem. After the update I get the GPS horizontal error.

I solved the GPS horiz error problem by going to advanced params and loading defaults (buttons on left). I had to re-cal everything. You may not have to re-cal if you just load pre-saved params. I didn’t know what I was doing so I loaded defaults first and then pre-saved params. I hope this helps.

Sorry for the bad info on the last post. You need to go to the full parameter list and on the right side of the screen you can select load defaults or load pre-saved. Be sure to select your platform on the pull down box.

Hi, I’m having the same issues with GPS horizon errors and have been experiencing other errors such as speed and bad acc. health. Have you managed to fix this?

I’ve tried loading the default parameters but have had no success.

Additional symptoms:

I’ve got quite high numbers for my external compass offset which I can’t seem to lower no matter how far I move it.

On the ground in stabilise mode, the pixhawk is able to get a good GPS lock and blinks green. The second I move over to any GPS mode however, it loses GPS lock and begins to blink blue!!

I should mention that the GPS module looks a bit rubbish (it hasn’t got any external markings at all) and some of the wires came out on the first day. I glued them back in and my first few flights went beautifully though!

I have had no crashes or even moved my quad since last weekend but I feel like the GPS module could be the source of all my problems.

Any thoughts?