GPS Horizon Error 5.1,5.2, 7.6,

I tried to post this earlier, but for some reason my post never appeared.

I have run into an error message that continues to warn while connected to mission planner.

It says "GPS Horizon Error 5.1"
The sometimes the error says “GPS horizon error 5.2”, or “GPS horizon error 7.6”. And sometimes it even says “GPS Speed Error”.

I have tried reflashing the firmware, replaced the GPS unit (both M8N), and still continue to get this error. I cannot find any information about this error. Does anyone have any ideas?

Ok, so yes, we need to document all the new pre-arm failure messages that have arrived with Copter-3.3. There are some here on the Plane wiki:
…and some more here on the Copter wiki:

Until we update that, those messages are coming from the EKF as it’s check the GPS quality. There’s not much you can do about it except try to improve the GPS quality some how by waiting longer, moving it away from any sources of interference (GoPro cameras, long range video equipment, etc), get a GPS with a bigger antenna, etc.

Sorry I can’t be of more help.