Servers by jDrones

GPS High HDOP error while arming almost every time

Hello, I have built a pretty big copter with APM 2.8 and firmware 3.2.1, pretty old I know, but I didn’t know what to get back then when I was buying it, so I got a kit with that. It worked pretty well, but after I mounted the fpv transmitter, I had crashes, I sorted that out, the transmitter was overheating the board, I mounted it in another place, all worked fine, but in the last crash before I did that, it crash-landed on the GPS, also people recommended to enable pre-arm check, so I did that, and now I get a high hdop error almost all the time, while the satellites are above 8 almost always!

Here are my questions:

  • How is HDOP measured? I heard that there is a bug in the firmware that treats PDOP as HDOP!

  • Is it okay if I just disable the pre-arm check and take off with 2.3 HDOP for example?

  • Can the FPV transmitter cause frequency interference (5.8Ghz) with the GPS, or maybe electrical interference?

  • Sometimes after restarting the board a few times, moving the copter around to another location or just calibrating the compass helps, but why?

NOTE: The HDOP values were higher when I removed the jumper JP1 to get rid of the bridge between the two electrical parts as I understand of the APM, but the current wasn’t enough, so I put it back and it seems to work sometimes.

well, it’s not suggested remove the pre-arm checks.
Keep your gps module on a stand and keep far from it extra wires and antennas coz will create high interferences.
If need perform a compass calibration better perform it in an area with less mag field

I did, my GPS away from all the wires as seen in the image attached, but you didn’t answer the other questions!
Anyways tomorrow I will try disabling GPS Lock pre-arm checks and see how it performs

https://drive.google.com/file/d/1t7qLjeytHVy7LljcUrdG5D28WukFNBRQ/view?usp=sharing

basically i cannot answer about jumpers coz i never focus my developments with that board.

1 Like

HDOP is measured from the GPS unit. There is no Bug, and even if there is, high PDOP is also a problem. You can not fix interference with a software fix

Do not disable pre-arm checks, unless you want the copter to crash.

Yes it can

Because it gets better GPS signal.

Listen to @Dave84’s advice

1 Like

I’m Yaros1 from another account. I disabled prearm checks and now everything works as expected! I don’t know why it was happening, but now without prearm checks all works like normal, the copter arms directly after getting gps signal! So I will leave it like this.

Well as previously said, it’s not suggested remove the pre-arm checks.
I recommend the repositioning of the gps module if necessary or shield the module with the appropriate tape

Yeap, all works normal until it doesn’t.

Servers by jDrones