GPS glitches / 89 bytes logs


I’m using a PX4…

I was first using the 3.1.3 stable release, loiter worked and was flying ok, but I had the 89 bytes logs problem…

Then I tried 3.1.4 beta, this one: … /PX4-hexa/

And the logs started to work, I was able to check all the information, but then I tried loiter… and crashes occurred… I was able to save it, only some carbon tubes of the landing gear were broken… Then checking the logs, there is lots of GPS errors…

First flight 3.1.4 beta:

Second flight 3.1.4 beta:

Then I reflashed the PX4 to the latest release with APM planner 2, its the 3.1.4 I believed, and did a quick flight to test the logs, and now I back to the 89 bytes logs…

Failsafe GPS-0
Failsafe GPS-1
Failsafe GPS-2
Failsafe GPS-3
Err: GPS-1
Err: GPS-2
Err: GPS-3

And the position changed from one position to another… This used to work good with the stable version…


Log 1:

Log 2:

Log 89 bytes:


Has anyone with the PX4 had this kind of problems??

So, if I use beta versions I’ll get logs but lots of GPS glitches, if I use stable versions I have GPS but no logs… Does anyone think my board is faulty??

Any ideas?? recommendations??


I’m getting the exact same GPS errors but I’m using APM 2.5.2. Did you ever figure out what causes these errors? Is it a bad gps module?

Your GPS is only getting a few satellites (5 tops).

There are no changes to the functionality of logging or GPS between 3.1.2 and 3.1.5

3.1.3 fixed a stability patch bug.
3.1.4 fixed a random memory corruption bug in the i2c driver in nuttx.
3.1.5 fixes a failsafe flyaway bug, compassmot on pixhawk, and an FRAM bug

As stated: none of those changes had anything to do with logging or GPS.

As to small log files - I’ve never had a problem with logging, and I use it a whole lot. Are they just empty log files being written to the SD card, or are there entire missing flight logs?

I’m still unable to get a proper GPS lock… will it be my GPS???

This is the error I was talking about of the 89 bytes logs:


Is not yet fixed on mine… I just tested 3.1.5 stable and remains the same.