Servers by jDrones

GPS for Yaw issues

Folks - I’m a newbie to the Rover world and am in the final stages of getting a large rover mower working. However, I’m now in deep water (for me) and need some help.
Basic setup:

  • Older large ExMark “zero turn” mower as test mule.
  • Dual linear servos operating control levers.
  • Pixhawk4 running Rover 4.0.0 firmware
  • Have base RTK and telemetry working.
  • Mower runs well and fairly tuned in “auto” mode w/ dual GPSs and mag compass
  • Recently removed compass due calibration issues resulting in poor pivot turns and installed two SparkFun uBlox F9P boards on the rover with front/rear antennas for yaw info.
  • EKF3 enabled
  • Have proper rover GPS location parameters loaded.
  • Using Mission Planner for most work and set-ups.

Have read and followed the recommended “GPS for Yaw” set-up w/ many hours trying different parameters w/o success.

Basically:
When rover GPS_AUTO_CONFIG set to 1 or 0 (0 recommended) and GPS_TYPE and TYPE2 set to 1 (not recommended) both rover GPS quickly lock and show “RTK Fixed” status on MP so I’m thinking the Serial port and basic GPS parameters are correct. However EKF on MP is red (not happy) and gives “EKF3 waiting for GPS config data” error.

With GPS_TYPE =17 and GPS_TYPE2 =18 (as recommended) and writing parameters w/o re-booting rover, MP will still show both GPSs as “RTK Fixed” and I still get “EKF3 waiting for GPS config data” error.

If I then re-boot the rover and re-connect, MP shows “No GPS” and rover goes into FS.

I’m lost…

Thanks in Advance!

Folks,

Just found where I can download Rover Firmware 4.1.0 which should help. Will update with results…

1 Like

Uploaded Rover 4.1.0 re-calibrated AHRS.

Current issue:
GPS and GPS2 both show “RTK Fixed” but EKF in Red and rover in FS mode. Also getting “Unhealthy GPS” and (Safety) flashing on MP.

MP Messages show “EKF variance” and then “EKF failsafe!” as last two notifications.

Clicking on red EKF opens “EKF Status” box showing both “Velocity_horz Off” and “Position_Horz_abs Off” in red.

I’m lost… Thanks in Advance!

Hi Steve, did you get anywhere with this?

I’ve got a similar setup and can see the the GPS returning a yaw but this isn’t being used by the EKF/Rover.

Nope. Still befuddled…

Just today I solved the same issue trough recalibrating the acc. + compass after I had switched to GPS for Yaw using two ublox F9s with 4.1.0 dev rover. I am using EK3_MAG_CAL = 6.
I also set GPS_INJECT_TO = 0 to make sure my external NTRIP corrections only reach the “GPS for yaw base”. However I had a Yaw offset after switching to EK3 and the whole GPS for yaw setup. Got solved by recalibrating both accelerometer and compass. Hope it helps.

Sorry. Found this in my junk mail…

Have had it work a few times but now have a new issue. 2nd gps is not receiving RTK corrections. Swapped chips and no change. 1st gps is locked in, 2nd never get past float. After numerous changes, starting to think it’s all in the pix hawk 4…

Are you up and running?

-Steve-

Servers by jDrones