GPS clock vs Autopilot clock synchronization problem

Hello folks,

I have some flight data coming from a 3DR Iris quad that uses Mission Planner V 1.3.32. I noticed in the flight log files that for this version the GPS clock value (TimeMS) doesn’t match the clock of the autopilot; e.g.: reading of a single datapoint (for the 2nd column of GPS and 1st column of IMU):

GPS, 3, 320332000, 1919, 11, 2.02, 39.7011412, -119.9014666, 0.00, 1559.98, 0.03, 12.08, 0.06, 494055
IMU, 494066, -7.647835E-05, -0.0001011863, -2.127141E-06, -0.2191673, 0.2198259, -9.776931
(for these two data points the time in milisec is 320332000 and 494066 respectively, where 320332000 is the number of milisec that have passed since the beginning of the GPS week and 494066 is the number of milisec since the autopilot started recording data )

Do you know of any way to synchronize these two clocks? that is, estimate what the offset is between e.g. GPS and IMU clocks?.

The autopilot clock is associated to every sensor of the vehicle (e.g. IMU, BARO, ATT, EKF, etc) but unfortunately it’s out of sequence with the GPS clock in Mission Planner V 1.3.32. I want to be able to find the time offset between these two so I can match GPS data to the rest of the sensors’ data. I am wondering if you folks know of any solution to this problem that was worked out at the time V 1.3.32. was being widely used. Thank you for your help.

why are you using 1.3.32? newer versions propagate the time in the log browser

Hi Michael. That’s correct. Newer versions solved this issue beautifully and this is a problem that most people don’t need to worry about anymore. Unfortunately I have some legacy flight data (produced with V.1.3.32) that I have to process, hence the question.