Gps 3D fix but blue led

Hi all,
I’m facing a real strange problem.

After three hours of regular flights in the past week today after powering up the copter and his Pixhawk clone with Drotek Ublox 8 gps the rgb led turn to steady blue (I disabled the arming button) .
After some minutes Mission Planner showed 12 satellites , 0,8 Hdop and 3D fix but the rgb status led remains blue.
On the map the copter position changed a little within a two or three meters in ten minutes,

Only once i got an error msg about gps horizontal velocity but I thought it was related to a bad gyro calibration .

I tried everything , several reboots , disable Geofence that was the only change I did but it did not help.

Solved !

The weird thing of the blue led status was that it let me arm the motors while in Loiter mode.
Then the led become red without any error reported in Mission Planner
Another strange thing was that when I try to download the list of dataflash logs I receive an errror.

The 4 Gb Micro SD card was full !

Once the Micro SD formatted , the led returns green