GPIO assignment Pixhawk (2.4.8)

Hi all,
I am using Ardurover firmware and I am currently trying to set AUX out as a GPIO. I have read the documentation on GPIOs — Copter documentation, and i am figuring out a way to trigger a relay. Below is the setting that i made via MissionPlanner (assigning first relay pin to AUXOUT1).

When i set the relay to high, it display a green icon. But multimeter displayed 0 volt when trying to measure from data line to ground. Is there any other setting that i need to make for this to work?

Take a look at the complete parameter reference for this 4.0 version, there is a parameter you need to change to make it work:

To use AUX1, I think this parameter shall be changed to zero.

Hi Bruno,
Pardon for the late reply. i didn’t found parameter named: BRD_PWM_COUNT

seems like there is already similar question raised. Link:can't switch on RELAY0 after arming when motor type is set to BrushedWithRelay · Issue #20637 · ArduPilot/ardupilot · GitHub
For DC motor with relay : GitHub - jazzl0ver/ardupilot-rover-l298n: How to setup Ardupilot based Rover with L298N motor driver to control with reverse simple DC brushed motors

As per mentioned by geofrancisGeoMuir on Error message "PreArm: RELAY_PIN=54, set SERVO13_FUNCTION=-1" :

I set these below parameters and perform reboot:

and also this:

once i toggle the io with this ui and measure pin with multimeter, it shows a 3.2V. I suppose it worked:

Yes it is working… the FC output is 3.3V.