GoogleSatelliteMap not uploading after update to 1.3.25

I have been running MP on an Asus hybrid with Windows 8.1. I recently updated MP to 1.3.25 when it popped up and now it won’t load tiles for GoogleSatelliteMap but does all the others just fine. I want GoogleSatelliteMap.

I have cleared my map cache, uninstalled MP and tried 1.3.24 and 1.3.20, deleted the folder and reset it, uninstalled and re-installed GE Pro, and tried to prefetch. No luck.

Any suggestions?


Just tried the procedure below and went back to 1.3.20 still with no luck.


Well, first of all, until yesterday, I never had an issue with the automatic updates. But from now on, I will be more careful.

I figured this out (Took me a few hours, but it was worth the effort):

I followed these steps to get rid of the current version 1.2.83:

  1. Un-install mission planner
  2. Delete the APM Planner folder C:\Program Files\APM Planner and C:\Program Files\MissionPlanner
  3. Go to command line and type pnputil -e
  4. Take a note of the drivers which Driver package provider is 3D Robotics.
  5. Go to C:\Windows\Inf and delete the .INF and .PNF files from the previous step
  6. Restart the computer
  7. I downloaded and installed 1.3.20 from here:

I found the steps 1 to 6 on DIYDrones:…Group%3A394475

I am not so sure if step 3-4-5 are needed, but that’s how you get rid of old drivers. It doesn’t harm to follow, they get re-installed anyway.

Tried updating to the latest beta this morning and its still not loading GoogleSatelliteMap tiles. It will show some parts of the planet and when I start to zoom it is blurry and doesn’t update or just gives me the 404 server error.

Uninstalled and deleted everything, reinstalled 1.3.25 and the problem remains.

Sigh :frowning:

Seeing the same problem. I think the Google Map provider code is the problem here and not Mission Planner. Also this may be a Google Map issue as well.


Good to know I’m not the only one at least. Hopefully it gets fixed soon.

I also noticed earlier today that YahooSatellite is now doing the same thing. Do you see that too?

Just updated to beta and the 404 errors are gone for the maps.


Thanks! That did it!