Google Earth Map lat/longs in Mission Planner need work

Well folks, I took my Thumper out on its first mission today.

It was a comical failure in that the Thumper tried to always barrel through my neighbour’s fence to the East.
I compared the lat/longs coming from my Thumper to those in my Magellan Hiking GPS and they agreed perfectly. The Thumper had a solid lock (big Green light) with 10 sats.

But the lat/longs in the Mission Planner with Google Earth were off to the West by 25 m.
So, do we have any way to calibrate the lat/longs in the Mission Planner. I need to fix this somehow.

I have not tried the “Learn” function as yet.


this is a google problem.

(I thought I had already sent this.)

Thanks for your note.
I understand that this case is a Google problem but what I am interested in is how others on this forum get around it.
Do they ignore the 25m offset or do they use a different map altogether. I looked at the other maps without any luck.

I am thinking of saving a Waypoint list ( with the errors ) , opening that in Excel & correcting the offset, then writing it back to the rover. That will produce Waypoints that will look badly in the MP but the rover should stay within bounds.


Can you post us a log, and also a screen shot of your Flight Plan window showing the drop down on the right side with the basemap.

“Real” Google Earth does all the corrections on-the-fly for different datums etc. In MP, you might be using a map that has a different datum or projection than you expect.

Thanks for your note.

I have attached a screen shot of my MP and it includes Home and Waypoint1. That indicates where Home is supposed to be and where Google Satellite Map thinks it is according to its lat/longs.
The difference is about 25 m. Hence my rover heads East from my backyard.

Being an MP newbie, I am not sure what log you want. Can you give me details so I can grab it.


Well, I can see that MP thinks you sunk into the center of the earth - note the Z-axis in the upper right corner.

It happens to me too, if I go to your location. Anywhere else shows either 0, or what looks like a proper msl altitude.

Sorry, I have no idea how to fix that.

I don’t think it is a Google problem, as it occurs with all base maps, and Google Earth itself seems to have a proper elevation for you.

what happens if you use bing/ another provider?

The latest version of Mission Planner now appears to have much higher accuracy in my neighbourhood.
This is great!