Good first flight but over correcting

What setting do I need to tweak to stop the plane over-correcting left and right. It doesn’t do it all the time but gets into a bit of a left-right weave occasionally when in Auto mode

Have you run Autotune? From my experience a couple of Autotune flights solves 99% of the navigation problems?


Yes I ran autotune and did a lot more than the 20 pitch and rolls they suggest.

Just wondering if there’s a simple change to one of the settings that can dampen this a bit.

If not I can run autotune again.