Going to loiter during auto flight bug

Hey guys

It’s been the second time I had this problem, my copter stop during a survey mission in auto mode and switch to loiter.

My setup is an octocopter, controlled by a Dropix from Drotek running Arducopter 3.4.6.

I was pretty far away this time, so not the best RC reception, but on the first flight the drone was never more than 200m away and I had great signal on my Taranis.

It could be the FrSky X8 receiver, a sort of fail safe that would change the value on the Auto switch, but never happened on any of my drones before, a bug on the Arducopter 3.4.6 or my Dropix having problems. I have no idea… :frowning:



PS : over all, I did 8 auto flight and it happened twice

Update 1 : I checked the RCIN in the log, Chan 5 “mode change” and Chan 8 “Auto” went, in PWM, from 982 to 874 and 2006 to 1323 respectively in less than a second then went back normal again, immediately after that the mode change from auto to loiter. No problem with all the other channel even Chan 7 “RTL”

How have you set up the failsafe on your x8r / Taranis? You should probably use the ‘no pulses’ option on your Taranis to prevent mode switching when you’re out of range.

Post your flight logs so people can take a better look.

Thanks for your reply Justin

I didn’t setup any failsafe on the receiver but my Taranis was in failsafe mode : not set.

But it’s weird because the first time it happened the octo was no more than 200m away, the RX on my Taranis was really high all the time.

I will upload both logs on my google drive and post a link when the upload is finished


First flight log

Second flight log


PS : Very weird on the first flight, it went to loiter without any RCIN change, I just quickly toggled the auto switch off - on to resume the mission

PS2 : Could be the Dropix, I had couple of issue with different boards, power module, led and GPS before, I might be the unluckiest guy in the world with Drotek.

1st flight:

I can see this happening in the log near line 567600 and as you suggest this doesn’t look like it was caused by your Taranis / reciever as neither your flight mode (Ch.5) or Auto switch (Ch.8) change when this happens.

2nd flight

The duration that CH5 dips to 872 and back to 984 is less than 200ms (just a single log line contains this lower value.)

This makes me think it could also have happened on the first flight, but it happened so quickly between log samples being recorded and so doesn’t appear in the log.

I would spend some time ensuring the failsafe is set up correctly on your Taranis and take it from there.


Hey Justin,

I already set the fail safe on my Taranis, I will let you know if the situation happens again.