Goblin 380 High speed porpoise at 25 meters/sec

Hi Rob,

I think this one is for you. I saw you have one of these too.

Goblin 380 is flying very well now, perfect heli for the Pixhawk, Everything fits with no mods to the heli.

I am seeing a small porpoise effect start at around 22 meters/second. If I adjust WPNAV_ACCEL_Z down from 450 cm/s/s to 350 cm/s/s the porpoise is eliminated at the expense of altitude control during a hard stop. At 350 cm\s\s running at 22m/s, the heli will loose 5 meters of altitude with a 180 degree direction change in auto. With WPNAV_ACCEL_Z at 450 it looses maybe 1 meter. Goblin flies very good as long as I don’t exceed 20 meters\second at that value.

looking at the data, DesPitch picks up some noise or spikes and the system responds to it. I slowed down my rate pitch PID’s but this does not solve the problem with DesPitch, just dampens the response. What drives the DesPitch value and how or what is causing the spikes? Or is this just pushing the limit of the controller or copter code itself.

Any comments will be appreciated.

I found a thread “Uncommanded periodic spikes in DesPitch and DesRoll” and the problem was described as timing jitter from the GPS unit. At least the timing spikes seemed to match up with the periodicity of the GPS 5hz rate.

It sure looks similar, but it does not happen until I am pushing the speed. I feel it is probably vibration related again.

I reduced the INS_MPU6K_FILTER from 20hz to 10hz and it did not improve, just made the tail wag when it did a hard stop in auto and heli did not seem as locked in as before. The glitch was still present in high speed flight.

I added a little more positive pitch 13 degrees with no real change. Then, I started adding rotor head speed, everything improved. I started at 2800rpm and I am now at 3100 and the little Goblin is flying very well at 22m/s. Vibration levels also improved, especially in fast forward flight. I am going to continue to push on the speed and increase rotor RPM until it gets unhappy again.

I wanted to keep the rotor head speed down for battery life, but the vibrations induced by a high blade angle of attack are causing too many issues (I think).

So, no more spikes with increased rotor RPM.


I ran into the same problem and encountered a nod at 22m/s. I have tried to adjust the pid but it didn’t help. I think that a parameter other than pid affects the pitch oscillation at high speed, but it is still not sure.
I will adjust the headspeed to see if it will get better, thank you

How do you have this helicopter tuned? We went to different tuning on helicopters that doesn’t lean on the PID and more on the VFF to get rid of these stability problems that they have on PID.

The old traditional tuning recommended tuning PID to the edge and then backing it off a little. But that does not provide stable flight at high speed.