Giving Up on Auto Landing

I think I’m going to have to give up the whole fixed wing auto land feature…

The main issues are:

  1. Constantly coming in way tooo high and long (overshoot).

  2. Does seem to use or care about the TECS_LAND_ARSPD and the LAND_PF_ARSPD

I have changed the various parameters so many times it is crazy. I even started changing them in much greater increments. Alas, to no avail!

I have NEVER had a shorter than needed or expected landing sequence, never. No matter what I do the fixed wing (nano talon) always comes in to hot and too long.

My Glide Slopes never exceed -10 deg. I line up on several waypoints, all that - It just seems like it doesn’t want to ‘sink’ on the final approach! It will ‘sink’ or scrub altitude great when in an auto mission just flying a pattern but oohhhh no… do the DO_START_LAND approach thing and forget it… Long and Shallow baby, every time.

I think I must have at least 50 attempts at this over many days (and using the same approach pattern).
I have messed with the LAND_PF_ALT&SEC up as wel. Im just wanting or trying to get it to initiate the 'lock heading, address speed, and flare baby flare - but no, no real changes…

Any others having this issue(s)? I mean I’m not trying to pull off any acrobatics here, just a long, easy, approach and land.

Any help?

… guess it wasn’t meant to be.
see a few you tube videos where people pull it off.
Even watched the hour long ardupilot auto landing seminar video (very hard to follow), printed out the overhead screens showing ideal & bad glide slopes. I reviewed all the settings called out there - again NOTHING has made this thing come in slowing down and on target.

oh well

1 Like

1 - is the throttle off during the descent?

2 - if the throttle is off and the airplane is coming in too hot, there is nothing that you can do to get rid of more energy. The plane is destined to fail from overspeeding. If I did anywhere near 10 degrees with an efficient airframe (like the believer), I would always overshoot the landing. I had to lower it to ~6 degrees. Try less.

What you’re not seeing in the air is that the airplane is probably gaining speed. The best way I have found to “undershoot” the landing is to reduce the TECS_LAND_SINK to a much lower value. This shallows out the “flare slope” and causes the flare point to move further away from the touchdown point. I really encourage you to try an approach at 5 degrees and 0.2 m/s TECS_LAND_SINK. Make your flare altitude 2m. Be careful that your aircraft does not stall when it slows down on that flare.

I really encourage you to not give up. Your experience and feedback here is incredibly valuable.

1 Like


I thank you much for the encouragement and responses.

  1. I do have the throttle pulled all the way down on the transmitter (if that is specifically what you are asking). The motor however is still wound (sounds the same) as it does when in flight in the auto mode (16m/S).

  2. Both the Mini Talon and the Nano Talon have a steep glide slope. When landing manually I can definitely do a controlled landing in a much shorter distance that I have laid out for the Auto Landing.

I do have (and mostly always have had) the TECS_LAND_SINK set to .2 (point two). I will lengthen the approach for 5 degrees and see what happens. You suggest the flare altitude be set to 2m. With the talons and landing manually when I cut throttle, I have to pull back on the elevator pretty hard to keep the nose up (talons are V tails). When I do that I air frame sinks nicely and quickly (steep angle).

I will make the suggested changes.
I thank you much for the encouragement and responses.

I disagree that there’s nothing you can do to bleed speed beyond what auto land currently does. If I land in stabilized mode, and I cut throttle and hold up elevator as needed, I can bleed off lots of speed and increase the sink rate/ landing slope, adjusting along the way to maintain minimum speed and hold sink rate. I can’t think of a better use of an autopilot than to do this automatically. A plane that I can land on an 8 degree slope this way, needs a 4.5 degree slope in auto land.

This is a CRAZY amount of space needed to land. If there are 100’ trees to clear, leaving a little buffer above them means I need 3,000’ of clear space to land? That’s ridiculous. That’s almost twice the distance.

Honestly, I hope I’m completely wrong and there’s a better way. I’ve tuned everything, including TECS according to the docs. I’ve increased and decreased sink rate parameters. It holds commanded altitude nicely, but refuses to follow a reasonable glide slope.

Your landing technique of holding up elevator with no power is a deep stall, not a traditional approach. It also indicates that your CG is probably too far forward.

You can also lower your land airspeed to reduce the energy your plane maintains prior to the flare.

I can see why you would think of deep stall based on my description, but this is definitely a traditional slope. I’m not trying to sink in a deep stall, I’m still aiming for a pretty gradual slope and very moderate sink rate compared to that. It’s definitely more than cut throttle and pull back.

A slippery airframe takes a second to runaway with airspeed, so it’s a delicate balance. But that’s kind of the point, that it takes attention to maintain the balance, which is an autopilot’s strength.

CG is well in the middle of the window, so that shouldn’t be a factor. Lowering the airspeed seems to have no effect as the AP isn’t able to get to it. It barely holds cruise speed during landing, as it’s always threatening to overspeed. It seems like the AP doesn’t know that if it pulls up elevator just a little it will slow the plane and increase sink a little to get back on glide slope.

This indicates for certain that your glide slope is too steep for the parameters you have set. Ardupilot and TECS is NOT designed for the region of reversed control. Its default parameters will prioritize maintaining the proper altitude OVER maintaining the proper airspeed. You may be able to get around this by increasing TECS_SPDWEIGHT or TECS_LAND_SPDWGT.

Do you have any suggestions for parameters that would allow it to auto land more like what it’s actually capable of? I followed the autotune and TECS tuning guides. Maybe I’m missing something. Oh, I tried setting the LAND_SPDWGT to -.9 (-1 is default scheme, so got as close as I could) to favor altitude over airspeed, but it still overshot by quite a bit.

Set it to 1.7 and try that.

What & how Lars_Meadoworth is describing how he lands is EXACTLY how I would describe how I land (when in stablized mode)…

He also describes exactly what I thought about the AutoPilot should be able to replicate.

I my situation I also need a steep slope …

all …
this is exactly what i am attempting to achieve.

what about the land_app_smax param?

After spending hours in SITL (in Realflight), it looks like adding a rangefinder very reliably improves the auto landing, not only with increased accuracy, but with just overall better behavior. Landings, in SITL anyway, went from 4.5 degrees to 6.5-7 degrees, and insanely smooth touchdowns.

I haven’t used a rangefinder in the real world yet, but if it acts like this then it looks like a no brainer at this point!

I don’t read any mention of reverse thrust to kill off approach speed for landing, is anybody using this successfully now?

okay - so now I need to start looking into adding rangefinder (Lidar i guess is best guest).

So, when looking at LIDARS that work w/pixhawk or mrobotics x2.1 (ardupilot firmware) I don’t see any ‘hands-down’ winners. Most all of them have some kind of issues. Mmmm

I’ve used reverse thrust and it works great. I think it’s the simplest solution. It’s scary to watch 40 degree descents, but it will do it. Make sure your prop is bolted on well!


There is no way to achieve this without some mechanism to reduce the energy of the plane. There are 3 methods that I know of.

  1. Flaps/Flaperons
  2. Reverse Thrust
  3. Deep Stall or similar slow approach

Without any of those techniques, you have to use a lower glide slope to avoid slamming into the ground during the approach/landing. That’s just physics. I use reverse thrust, RTK in place of a rangefinder, and it works well for me.

  1. no flaps on plane.

  2. prop on this fixed wing screw on - so reverse thrust would cause it to spin off.

  3. My aim the whole time has been to do the slow approach thing (which is really all that needs to happen); however the tecs_land_arspd & land_pf_arspd parameter seem to get ignored and the approach (past 2nd to last waypoint) dont seem to get implemented.

They will always be “ignored” if the throttle is already at 0 and the speed does not decrease. They aren’t going to pitch up to gain altitude and overshoot the landing even more.

"… they will always be ignored if the throttle is already set to 0 … "

Point being - the throttle doesn’t get lowered (automatically) like I am expecting it to be (and should be by the autopilot via these 2 parameters)

I don’t want to hyjack the post, I’ve loaded blheli on the esc on my hawksky testbed plane to play about with reverse thrust a bit, but I’ve only an old APM in it so I can’t do the full automated landing sequence. Cheers Marty.