I managed to get the latest master (of diydrones/ardupilot) onto my local machine, using Ubuntu on a virtual machine in Windows.

However the WEB interface on my account shows the latest code of Rev 3.1-rc6

I can’t get my latest local copy to the server account so it shows on the WEB interface.

Obviously I need my branch to have the latest plus any changes I may have made.

If I try “git merge upstream/master” or make a small change on my local and try a commit, I get
"not possible because of unmerged files".

How do I get my branch on the server to equal diydrones/ardupilot master?

My feeling is that I have to do a pull from the ardupilot master to my branch master.

But I try that and I get all bogged down. The pages it sends me to don’t seem to match what I think is going on.

I’ve tried to read the help on github I get merge exceptions: They say “fix those first… but don’t say how”.

Sorry, I feel as though once I get oriented I’ll be on my way.

I’ve worked on embedded linux for some time on various platforms, even have a BBB. But haven’t worked with git, but for this project it is essencial.

As it is I can obtain edit and compile the code in master, but can’t share it or synch it with master.