Servers by jDrones

Gimbal Control in Auto Mode | Do Set ROI

(Oliver Zöller) #1

Hi guys! Since this community has been so incredibly helpful, I’ll hereby start donating $5 for each solved problem. :gift:

Here we go: I’m trying to do some photogrammetry on my Tarot 650 with a GoPro and a T3-3D attached.

The Auto flight plan works well except the camera doesn’t point at the ROI (sometimes just above it, sometimes somewhere completely different) and I can’t manually override the gimbal movements. There is most likely a rookie mistake somewhere in there and I’d be glad to find out where.

Here is the Flight Plan as a screenshot:

Here is the log:

And here is the video showing the camera movements.

Thanks a lot in advance!


(Tim Jones) #2

Are you setting ROI at each way point
you don’t need to do that if the intention is to have it look at the same place the entire mission
on ROI will be followed until you give it another ROI

(Oliver Zöller) #3

Thanks for that note - I read somewhere that it’s not necessary anymore in 3.4, but wasn’t sure.

Any advice why the camera isn’t pointing at that ROI though?

(Tim Jones) #4

I think it is too many ROIs
try it with a single

(Oliver Zöller) #5

Alright, I’ll try that tomorrow - but even in the beginning, the camera points to the sky.

Also, is manual override always impossible?

To me, it looks like the Pixhawk is only turning the gimbal, but not the copter. Thus, without 360 degree gimbal control, it can’t point at the target.

(iseries) #6

Right, the ROI needs to be calibrated to the gimbal you are using. There are several parameter that need to be set to make this work correctly otherwise when it outputs the PWM to the gimbal to point it at the area it will be off.

The software is designed to control both 2 axis and 3 axis gimbals and you need to tell it which one you have.

For a 2 axis gimbal it will turn the copter so it is facing the region of interest.

If we could get a copy of the flight data we can see what parameters you have set for the gimbal.


(Oliver Zöller) #7

Thanks, I’ll grab the parameters tomorrow when I get back to the quad.

I have a 3 axis gimbal, but it can only turn half a circle, so if the copter doesn’t turn with it, it won’t be able to face backwards. Is there a way to treat it like a 2 axis gimbal? Or a better solution?

(chris rey) #8

@o_zoeller, hi, I also have a Tarot 3D, but at this time was not able to pilot it through the Pixhawk, could you please share your setup? At this time I am able to pilot the gimbal manually through the remote, but was never able to use the SET ROI commands in a mission, thanks, Chris

(Oliver Zöller) #9

Alright, I solved it with a workaround. Thanks a lot everyone!

Apparently, as @iseries pointed out, Copter either uses the gimbal or the yaw to point at an ROI. This poses a problem when using a 3 axis gimbal with less than 360 degree field of view. In my example, the camera could not point at the ROI when the copter faced away from the target.

So I disabled yaw control on the gimbal, pretending to use a 2 axis one. Thus, the copter now yaws toward the target and it is in view.

Maybe this could be fixed in the next release.

It took some time to set it up, but the Tarot 3D works fine with Pixhawk passthrough. Here are my parameters: Params13112017.param (13.4 KB)

And this is what the gimbal page looks like (I manually put in the settings I disabled due to my problem):

(Amilcar Lucas) #10

The Yaw issue when the gimbal does less than 360 deg is a known and documented missing feature.
And you found the known workaround for it.

(Oliver Zöller) #11

@amilcarlucas Oh, good to know! Thanks for the info!

(chris rey) #12

thanks for sharing!

(chris rey) #13

Hi, after disabling the Pan axle, my drone (Tarot D3DIII connected via sbus) was able to face the ROI point and the tilt gimbal function was operating correctly in Auto mode. Thanks! One question, before you disabled the Gimbal Pan axle, was the Gimbal working correctly in Auto mode? I mean facing to the ROI point? For me, it was not the case.

(Keith Downes) #14

it wont point the copter to the ROI even with WP_YAW_BEHAVIOR=3?