Getting an AR8020T 8 Channel Receiver to Talk to Cube Orange

I am having trouble getting Mission Planner to “hear” my AR8020T 8 Channel Receiver.

Symptoms: I go to Radio Calibration and see that there is no radio connection made (its just all blank). I also get the audible warning that there is no RC Receiver.

What I have:
*Cube Orange running Rover 4.2.2

*NX10 Spektrum Radio that 100% talks to the AR8020T 8 Channel Receiver. I can plug a battery in the AR8020T and a servo and move the servo arm just fine. Orange light is lit on the AR8020T.

I have made multiple cables to try to figure this out.

Attempt 1: Since the AR8020T 8 Channel uses only the “new” SRLX2 protocol I can’t hook it up to the Spek/DSM 3 pin connector on the Cube Orange. I did make a cable to test this. It went from the 3 pin servo connector (on the servo rails of the AR8020T) to the 3 pin Spek/DSM port on the Cube Orange. No go.

Attempt 2: Made a new cable that goes from the AR8020T’s 3 pin servo rail connection to the TELEM2 port on the Cube Orange. Through extensive research I connected the Red wire (pin 1 of the TELEM2 USART port) to the red positive voltage pin of the AR8020T. I connected the Ground pin of the AR8020T to pin 6 of the TELEM2 port which is the ground as indicated below:

**I am with the understanding that the USART can do everything that the regular UART connection can do.

I then connected the signal wire of the AR8020T to pin 2 of the TELEM2 port (indicated as MCU_TX in the pic above). I AM CONFUSED AS TO WHETHER OR NOT THIS IS THE CORRECT PIN, can anyone confirm?

Next I looked up which serial port the TELEM2 port on the Cube Orange is associated with and decided it was the Serial2 parameters within Mission Planner as derived from the pic below:

Next, as per instructions found HERE, I set the following:

  • Set [SERIAL4_PROTOCOL] = 23
  • Set [SERIAL4_OPTIONS] = 4
  • Set [RSSI_TYPE] = 3

Mission Planner does not recognize the receiver still.

Can anyone help me figure out where I went wrong?

You have done everything right, except you should be setting SERIAL2_PROTOCOL and SERIAL2_OPTIONS in the last step.

Make sure your TX is powered on before powering the flight controller