Geo tag error "There was a problem with image"

I have a mission with 62 images flown in 2017, and used nearly every semester since as a classroom example of Geo tagging and using Pix4D mapper. I used a 3DR Solo with a GoPro 4 to take the images. This semester when I tried using Geo tag in MP, it did create GOPR0xxx_geotag.jpg files, but the message screen has a message “There was a problem with image” after each image and the geotagged images cannot be opened. Has there been a change in MP that would cause this error after it has worked successfully countless times using the same images and log file?

Any chance you could provide the data set?

Of course. I can share it in my Google drive or One-drive but wouldn’t I need an email?

Hi, I am having the same problem. Here is the link for the dataset:

It contains the log file, the images and also the GeoTagImages button’s output files. As you can see only one image got tagged, the others are just empty jpgs.

Also, the Geo Ref Images window lines the images and pins up correctly:

What am I missing?

All right, I just cloned and built the latest version of MP and it works now…

some help:
Install git

git clone
git submodule foreach --recursive git submodule update --init

Rest is on the Ardupilot Wiki