Geo-Fence not working at all and menu disappearing


I’m using Mission Planner 1.3.74 with ArduPlane V4.1.0dev (12f569dc) with a FC Matek H743-WING.

I’m trying to setup geo-fence and nothing is working at all.
When I launch Mission Planner, I can see the menu Geo-Fencing however as soon as I connect to my FC via USB cable, the Geo-Fence menu disappears. What’s wrong with that? Did I miss something?

I even enabled the parameter FENCE_ENABLE =1 without any success.

Please help!

With dev AP code you have to use latest beta Mission Planner.

I’m already using the latest beta version of Mission Planner…

Works for me with the Mini version of that FC which uses the same firmware target. Latest -dev from today. and as always latest MP Beta.

Ah, actually it’s Copter. I’ll try with a Plane.

Same in Plane.

It is still not working :frowning:

I re-flashed firmware again with the following file using STM32CubeProgrammer and checked option Full chip erase just to be sure.

I also clicked button “Check For BETA Updates” in Mission Planner to be sure I’m using the last version.

So, as you can see on attached screenshots, before connecting to the FC, I can see the option “Geo-Fence” in the menu. However, as soon as I connect to FC, this option menu is not there anymore.

I’m stuck!

This has nothing to do with the firmware on the Flight Controller. I think you need to read the Wiki about setting a Fence:

See the pulldown in the top right that says “Fence”? See those black circle icons on the top left? Run the Simulator and figure out how it works, you do not need a Flight Controller connected.

1 Like

Thank you for this clarification.

In the documentation it was indicated “You can then right-click and choose geo-fencing upload to send your fence boundary to the APM” and since the menu was not there, I though that there was a problem.

Thank you for your time.