Geo Fence does not work in Mission Planner and Arduplane?

Hi, it seems geo fence is not supported in Mission Planner 1.3.74 and Arduplane 4.0.6, is that correct? I tried QGroundControl and got the same error, more or less.

Is it an issue with Arduplane, missionplanner/qgroundcontrol, or both?

You need to be using MAVLink 2 for your serial protocol, should work over USB as that is MAVLink 2 by default.

I am connected by USB and am using mavlink2 by default - I have tried it by telemetry radio also (probably mavlink1), same error.
connected by usb

My flight controller is a Pixhawk 1. SOAR mode is not available - I think that means my board has memory limitations that results in some Ardupilot features being removed. Is GEOFENCE one of those features?

Possibly. I’ve had trouble with fence on some of my older boards. I haven’t put a lot of effort into sorting it out.

I’m pretty sure FENCE is supported on all boards that run Arduplane regardless of flash space. if not, it’s not well documented.

Any resolution to this? I’ve been using my best google-fu, and have not found any solutions to day… was hoping in 8 months this would be resolved…

Started another related topic due to the recommendation that we be on Arduplane 4.1, which isn’t released yet…