Gazebo stuck at "Preparing your world..."

Hi everyone,

I am trying to launch Gazebo-8 simulator via WSL - Ubuntu 16.04 installed on Windows 10 with Xming. I have installed Gazebo as described here: (ardupilot tutorial - link- seems to be a bit messy, but hopefully I have everything covered). Everything went OK and the program starts, but stays like that forever:

And here’s an output of Ubuntu terminal after I call Gazebo:

Should I worry about those warnings? The “Sleep time…” seems to be a common problem with low clock resolution (400ns) of Ubuntu running from Windows.

I’ve found some reference to this problem in Google that there’s a bug with custom worlds and renaming it to “default” should help - but it didn’t ( Other suggestions state that it just takes time to download the worlds at the first time, but waiting for about an hour didn’t change anything. Then I set up SITL (forgotten to do it before Gazebo) and this one seems to be working well.

Do you have any suggestions what could’ve gone wrong here?


Did you try to launch just gazebo on WSL ? I am not it works …
Try gazebo --verbose . It should launch an empty world an validate that everything is working.
But it looks like the first to warning you get will prevent you to going further …

It looks like your PC issue to me , Gazebo does require high computing power
as I described at the first of repository with quoting myself, Gazebo has requirements

Native Ubuntu Xenial(16.04 LTS) able to run full 3D graphics.

Note : Virtual Machine such as VMWare Player does not support full 3D graphics.

Gazebo require a computer that can run full 3D graphics along with the physics engine,
it may not seem to require much computation but it does both on CPU & GPU.

Just run
gazebo --verbose
as khancyr said, I bet it won’t be able to start or very slow even with the empty world.

Thanks for your responses.

Yes, I’ve tried running gazebo alone and it gives exactly the same result. I don’t think that PC should be an issue as it’s a quite new i7-powered machine, but possibly Windows’ Subsystem doesn’t support full 3D graphics (similarly as VMWare Player you’ve mentioned).

I’ve googled that Xming server has some bugs, and indeed: using VcXsrv instead solved the first two warnings (about screen resources and XCB error). Now there are only the warnings about “skipping sleep” and queue limits being reached (“Queue limit reached for topic /gazebo/default/physics/contacts” and later “Queue limit reached for topic /gazebo/default/user_camera/pose”). I’m wondering if this low clock resolution is not the cause of my issues, but it seems to be a problem with WSL that I cannot hurdle… will try a native Linux later.