Gas Heli loosing altitude in Loiter

Hi Guys,

We have a gas heli (XLV Benzin) controlled by Pixhawk and a governor to maintain the engine RPM at 12000 and the head speed at 900 RPM. The objective is to achieve an autonomous mission !

The machine flies well in stabilize mode, but it looses altitude in Loiter and starts a descent. According to the log, the helicopter receives a negative collective pitch command which makes it loose altitude. You can see the machine fly here : We copied Chris Olson setup in the traditional heli tutorials.

Does anybody has encountered a similar situation? Any troubleshooting ideas?

Thank you,


Here is the link to download the log of our last flight. I tried putting in directly on the site, but the file was too big. Also, I made a Zip with all the files created for that flight since I wasn’t sure what was needed.

Thank you all for your help.!AjpWnmMQ3FXegodSVzfpXtRBeLjqKQ

I didn’t see where Loiter was engaged in that log? I see Alt Hold engaged a couple times. But I do see a problem with the tuning of your helicopter. I would recommend putting in the params for 3.6 for tuning it. They can found in the frame params dropdown in Mission Planner for Copter3.6 Heli from the full parameter list page.

Those params will set your position controller, nav and loiter controllers for 3.6, as well as dropping in ATC tuning defaults.

Is this a flybar helicopter? I note you have flybar mode turned on. In the vid I didn’t see a flybar on it. And the tuning looks really soft for proper control of the machine.

You’re right for this flight we didn’t try loiter since ALT hold wasn’t working properly. Also, our helicopter does have Flybar but it’s hard to see in the video.

I updated arducopter to 3.6 and uses the presaved setting called TradHeli_Copter36_Setup-MP. param. When I did that I had a couple of messages telling me that the value that was putting in were out of value.

Is there values that we should change in the parameter since we have a big gasser Heli or we could try flying it like that?

I attached our new parameters to that messageParametres36-2018-11-07.param (14.4 KB)

Thank a lot for your help it means a lot to us!

Ok, being it is a flybar there’s some changes you’ll have to make to the default params. The ones you have to change are these


It would’ve been really scary to fly it with the previous settings as the Position Controller wasn’t right. But now that you have the new settings I expect it to work.

You’ll have to double-check your tail settings and make sure those apply. If it seems too “hot” or “loose” on the tail you can adjust these. Turning them up will make it “hotter”, turning them down will soften it. The VFF can be turned up without oscillation problems. The P, if it gets too high, will cause rapid shaking of the tail. The D-gain can be turned up first if it seems too “loose” - it will also cause rapid shaking of the tail if it gets too high. Most helicopter tail servos I’ve run into can handle D of around .007 and P of about .25-.28

Also, the VFF’s for pitch and roll should work for flybar. But if it seems too soft on control response turn those up. Typical is .25-.28, but it will depend on the weight of your flybar paddles, and how much headspeed you are using.

So do a little tuning and double checking on these above noted settings, and then you should be ready to try Alt Hold again.

Hi Chris

We did another flight with the new setting and althold did a much better job. However the hover collective position seems to be off since when we put it in Althold it start to lose altitude, but when we put the collective at 50% the helicopter stay at a stable altitude.

We also tried Loiter and the result were not so great. The helicopter started drifting rapidly to the left, which is weird since we tried Loiter before changing the setting and it was stable on the other axis than the altitude.

I attached a link to the log of that flight.

Thank you for your time.!AjpWnmMQ3FXegodos-TR8y2k6z_lmA

This is normal. In any of the altitude controlled flight modes the collective position in the middle is no change. By moving the stick up or down, you request a climb or descent rate to the autopilot. You can set your stabilize collective curve to match the altitude controlled modes by using the IM_STAB_COL_1, 2, 3, and 4 parameters. IM_STAB_COL_2 & 3 set the middle stick position in Stabilize, so when you switch to altitude mode the helicopter doesn’t suddenly jump up or down.

I see what appears to be Loiter engaged in that flight. But it’s difficult to tell much from it because the log shows significant input for the aileron and elevator from the RC. Which is going to make the helicopter move.

I also see quite high vibration levels on x, y and z axes. And this is causing significant clipping on IMU3, and some clipping on IMU’s 1 & 2

Vibration levels this high can cause significant problems in Loiter because it makes it hard for the gyros and accelerometers to know if the helicopter is moving, or if it’s sensing vibration. So my opinion, you need to do something with your mount to at least get the x, y vibrations below 10. They are currently 20 to 30 in hover, which is pretty high, and the y axis spikes to over 50 in Stabilize when you are using harsher control inputs. This is going to make the helicopter very twitchy and hard to fly.