Servers by jDrones

FYI Mavlink Timing Out via radio connection


(Cillian de Paor) #1

I am making this post as a solution to an issue I spend hours and hours on and only now solved. Hopefully it can help someone. This is for any non 3DR, knock off type radio eg, from banggood.

SOLUTION: Switch the Rx and Tx leads on both the ground and air module. In other words… switch the orange/yellow with the green/teal coloured wires. And connect on mission planner.

Problem that the above solution solves (Really everything is setup correctly):
I am having issues connecting to mission planner via the radio. I am pretty sure I have a clone and not a genuine one but it should definitely be working. The normal wired USB connection from Pixhawk to laptop connects mission planner perfectly but not via the radio.

I have the driver installed
Baud rate set to 57600 on the driver and in mission planner
Flow control in devices on windows is set to none
I have the correct COM port selected (COM7)
Both the Ground and Air modules display solid green
Air module is plugged into Telem1 (i have also tried Telem2)

Mission Planner Version 1.3.51.0
Firmware: ArduPlane V3.8.4

Driver website I am using for Windows 10:
https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers

Exact Pixhawk:
https://www.banggood.com/Pixhawk-PX4-2_4_8-Flight-Controller-NEO-M8N-GPS-Radio-Telemetry-PPM-OSD-3DR-p-977597.html?rmmds=myorder&cur_warehouse=CN

Exact Radio (from banggood link above and not this website, but this is the one):
https://www.peggybuy.com/product/1set-3dr-500mw-radio-telemetry-433mhz-915mhz-air-and-ground-data-transmit-module-for-apm-pixhawk-flight-control-fpv-compact-size-141547?currency=EUR&gclid=CjwKCAiAtorUBRBnEiwAfcp_Y_zwfsXOha5g8zhpLJLjrz8k9vRVcbeBVl-bt2HIoN9I98EWP3iA9xoCX74QAvD_BwE