Futaba T12K Continuous Beeping [SOLVED]

I’ve had this transmitter for over a year. It is modified to have its output amped up by 1 watt. It is otherwise normal. Today it started to do this:

  1. Turn on 1W amplifier and then turn on T12K
  2. RF function check is completed good and the T12K turns on as normal
  3. It starts to do the fast paced beeping and the battery low indicator that pops up in the upper right corner starts to flash.
  4. RF transmission to the drone is fine
  5. The battery is FULLY CHARGED (2S LIFE)
  6. The indicated battery voltage as shown in the blinking battery icon in the upper right is showing 6.7V and persists through almost all menus
  7. The battery failsafe is on and is set to alarm (fast paced beeps) at 5.9V
  8. No switches/lever/menu items will stop the beep+flashing battery icon.
  9. Seeing as this transmitter has worked as modified for over a year I do not think my modification has caused this but I’m willing to entertain anything.
  10. When this started happening at the field I immediately checked the battery failsafe voltage as I was sure that I maybe somehow fat fingered the setting. Oddly enough, it was at 3.8V instead of 5.9V. No idea why.

I can’t find anything in the manual except Battery Failsafe Release, which I cycled through that and still it will beep+flash at me. I can’t find any reference to this problem in the 192 pages of the T12K manual.

Anyone have an idea?

SOLUTION: Futaba has TWO settings for battery low issues. First is Battery Failsafe voltage, this is when the transmitter will automatically send changes to the aircraft such as flight surfaces neutral or other things that you have told it to do.

The other setting is WARNING setting, below which it will beep like crazy to tell you that you have passed the low voltage alarm setting. Somehow my transmitter set this to “<.0” which means it will continuously beep even though the voltage is 6.7V. It works fine now that I set the failsafe to 5.8 and my warning to 6.0V.