Funny bug in EKF 3 ?!

Thats a STM32F427VIT6 == FMUv2: Single board with STM32427VI processor

edit: Nice little FC, price is quite good, do you know what sensors are installed (hard to see from picture) I mean IMU, MAG & Baro

@mike can you tell us more ?

Sure, in all it’s sordid history :slight_smile:
It is a Pixhawk 1, fmuv2, design and after you figure out the errors in the pin labelling it is really one of the better mini pixhawks because it has more of the original features than many of the newer mini’s, like the adc ports.

This thread has been around since it first arrived on the scene so it is certainly possible that the manufacturer, who ever it is, fixed some of the errors.

Patrick, before using this board, read Mike’s thread.

  1. The pinout is a nightmare, be carefull
  2. This board exists for several years now, you can get it cheaper than on banggood. It’s now maybe € 40,-
  3. It has a MS5611 baro, BUT: the sloppy hardware designer obviously didn’t care about the MS5611 powersupply. After i used an external MS5611 with correct capacitor, i got much more stable readings (before my flight height was limited to 1 meter by firmware)
  4. Reliability is quite good. I had never issues and i use it for more than 2 years now

Thanks Mike,
I am asking you the question about sensors as I find it hard going through 100 pages of repetitive discussions to find the answer.

OK thanks @fs007 for the research :slight_smile:

Sound like your initial question ?!?


  • ST Micro L3GD20H 16 bit gyroscope
  • ST Micro LSM303D 14 bit accelerometer / magnetometer
  • MEAS MS5611 barometer

They can/could have changed things too.

1 Like

Yes of course, that problem isn’t solved yet

Patrick I think you are confusing the older PX4IO?

The Pixhawk1 is the FMUV2, the PIxhawk 2 is the original 3DR cube in the Solo, FMUV3, Then the newer FMUV4 was the Pixracer etc…

I should have written the original PixHawk was running on fmuV1 was short live and most clones are running on fmuV2

i flashed fmuv2 firmware, but i observe, that FlowHold mode is gone now !?! (message in mission planner: “no such mode”) i think this has something to do with 1MB limit ?
Ther was a check some time ago, to verify whether the chip has 1MB or 2MB. I did this check and my Pixhawk lite appeared to have 2MB

shall i flash fmuv3 firmware or better Pixhawk1 firmware (that had allowed FlowHold mode) ?

“I should have written the original PixHawk was running on fmuV1 was short live and most clones are running on fmuV2”
Patrick, Yes there you go.

FS007 I don’t think that has anything to do with the fmu version but rather some of the features do change from version to version of the Ardupilot firmware releases. Some features are removed and new ones added and some they change the name of the parameters. So it is probably the version of Ardupilot not the fmu version. All of the fmu versions should have the same Ardupilot features and as far as I know they have not exceeded the 1mb limit yet, purposefully.

Then there is this:

" rmackay9


I think what’s happened is the flight controller being used suffers from the 1MB limit so Mission Planner is loading the fmuv2 firmware instead of fmuv3. If you manually download the fmuv3 firmware and then use the “Upload Custom Firmware” to load it to the flight controller it will probably work.

I’ll have a chat with the other devs on the weekly dev call about this."

This implies that there are some features now that require a 2mb fc. I’ll have to update myself on this subject.

i used the so called “latest” from download section, which is 3.7.0
PixHawk1: FlowHold mode present
fmuv2: “no such mode”
fmuv3: FlowHold mode present

Question is: can i use fmuv3 for my Pixhawk lite ?

Interesting, @fs007 can you open the cover and tell us exactly what is written on the STM …if it is a STM… :-:smiley:

Sorry, that would mean quite a lot of disconstruction work.
meanwhile i flashed fmuv3 and that seems to work … i’ll do a short test flight … fingers crossed

1 Like

Cool , sound like good news

just back from my test flight with firmware fmuv3:
everything worked as it should, except one thing: i can’t fly higher than approx. 1 meter.

Have you tried with flying althold wih ekf2

as far as i remember: yes that worked
honestly: i’m using arducopter since 3 years now and you can believe me, if i could never fly higher than 1m i surely wouldn’t have used it.
i see 2 possibilities:

  1. there is something wrong with my parameters
  2. or with EKF3 ?

Here what I suggest, make a test flight with ekf2 and is proven OK on both on althold & flowhold then you/we can open an issue on github