Servers by jDrones

FTDI Drivers incompatible with Max OS X 10.15.4?

When attempting to install FTDIUSBSerialDriver_10_4_10_5_10_6_10_7 as part of apm_planner_2.0.26_osx.dmg I get the error:

This package is incompatible with this version of macOS.

See screenshot:

I believe as a result APM Planner doesn’t detect the Pixhawk 2.1 Orange Cube. I would expect a com port option like cu.usbmodem01. Instead, I get the error:

No valid device found. Check to be sure your APM2.5 or Pixhawk/PX4 device is plugged in and drivers are installed.

I’m curious if I’m doing something wrong? Thanks everyone.

Due to several changes in the ardupilot firmware path, which is used for downloading, the install firmware dialog is broken. Unfortunately it is also broken in the latest 2.0.28-rc1 release. I hope I can fix it in the near future.
Until then you should use https://firmware.ardupilot.org/Tools/APMPlanner/beta/apm_planner_2.0.27-rc1_osx.dmg

2 Likes

You can download the correct drivers for Catalina from
https://www.ftdichip.com/Drivers/VCP.htm

The driver has been signed by Apple and is 64bit
The package you are trying to use is too old for Catalina.

2 Likes

I am having similar FTDI incompatible driver issue on my Mac 10.13.6 High Sierra, but with a twist. After installing APM 2.0 8-18-18 version that was previously on my Mac, the Pixhawk WAS sending data to APM on my Mac and I could see the GPS, elevation, and the map was local to where i was, and I WAS receiving the audible disarm alerts, but telemetry was not working. I had red on both sides (ground control and on the craft) So i watched a few YouTube videos on getting telemetry working. The only way it could connect for the radio was to use a DIFFERENT port than what had been used by the computer to connect to the craft. I dont mean a different baud rate, I mean a different serial connection entirely. There had been 4 serial connections displayed. Telemetry started working when I selected the cu bluetooth incoming port at 57600. It reported that connection was a success and populated all of the correct radio parameters and downloaded 417 config settings. But immediately thereafter and until now, despite reinstalling the serial driver and now the APM 2.0 software beta 2.0.27 version that was suggested above , the ability to connect from APM on the computer to the craft has disappeared. It only allows me to connect with the radio 57600 connection and the other connection I used previously to connect to from APM to the craft has disappeared, thus I no longer receive any GPS data, nor any other data from the craft, nor any auible alerts. Its just sits in silence. Frustrating…any advice would be GREATLY appreciated.

My suspicion is that the xml that’s being read in after start up of the APM app that I believe is saving parameters for the drone and for telemetry settings where the parameters for each are correct (both reported or demonstrated success) . I wonder if it is what’s causing this. The driver needs to be device specific somehow for the port. It connects to the computer via the USB when it hasnt been deleted or disabled and it works. Telemetry shows green on both ends even though no data being received by radio is supposedly correct.
I did read about following instructions for removing the conflicting driver. I did not find the D2XXHelper driver. I have reinstalled the FTDI driver 4 times now. It has worked after the first time and after the last install (briefly to connect only) then reports the connection is missing.

what I see in terminal is:

apples-MBP:Extensions apple$ ls
ACS6x.kext FTDIUSBSerialDriver.kext

apples-MBP:Extensions apple$ ls /dev/cu.*
/dev/cu.Bluetooth-Incoming-Port (this connection appears)

apples-MBP:Extensions apple$ ls /dev/tty.*
/dev/tty.Bluetooth-Incoming-Port (this connection appears)

I dont find any USB connections, despite the fact they were used to connect from APM to the craft through the USB earlier:

apples-MBP:Extensions apple$ ls /dev/ usb /
ls: /dev/ usb /: No such file or directory

apples-MBP:Extensions apple$ ls /dev/usb.*
ls: /dev/usb.*: No such file or directory

Previously, immediately after installing the FTDI USB serial driver I saw two usb drivers in the connect dropdown in APM Planner 2.

The two I previously saw were labelled as cu.usb and tty.usb. The cu.usb allowed me to connect to the laptop using the USB to microUSB cable. Now there are no drivers labelled as either one.

apples-MBP:Extensions apple$ ls /dev/cu.usb.*
ls: /dev/cu.usb. : No such file or directory
apples-MBP:Extensions apple$ ls /dev/tty.usb.

ls: /dev/tty.usb.*: No such file or directory
apples-MBP:Extensions apple$

I could go along with the theory that the cable wasn’t designed to connect to the drone…IF the drivers were still there. I SAW it working…and I SAW the other two usb drivers. I don’t know how to get them back.

I do have the same driver FTDI driver (FTDIUSBSerialDriver_v2_4_2) as you have recommended above. i downloaded it from the exact same page on the website and it state for Mac OS above 10.8. I have completed the 5th reinstall of it. I also have now installed the beta 2.0.27 version that was suggested above. I am still having the same issue of only the two bluetooth drivers and not the usb drivers, so I am no closer to resolution as no data is being received from the craft whether connected directly by the USB or thru telemetry. Is there anyone who could perhaps guide me via a zoom meeting? I have logs since installing. The first from May 22 shows installlation. The second from May 24 shows receiving coords, but was still having telemetry issues. Later I followed the youtube videos to enable the temetry but killed the connection for APM to the drone. (May 25, 26) Where can I upload these?

@Arne-W thanks for your reply. When I download the link you provide, however, I still get the same error (see screenshot).

Link URL: https://firmware.ardupilot.org/Tools/APMPlanner/beta/apm_planner_2.0.27-rc1_osx.dmg

@mboland I am able to successfully install the 64 bit signed driver you link to, but strangely I’m still not able to select a “Firmware Upload Com Port,” even after the driver has been installed (see screenshot).

Screen Shot 2020-05-27 at 5.27.51 PM

I’m starting to wonder if I’m the only APM Planner user on a 64bit MacBook Pro…maybe I need to buy a cheap netbook or something…

I had a similar problem as you’re describing where the needed ports did not appear even after successful installation of the FTDI driver. My Mac is 10.13.6 and required the new driver also. I reinstalled 2.26 and 2.27 versions of APM multiple times. I reinstalled the FTDI driver for Mac 10.8 or higher 5 times. Still no driver… Then I did something that had been missed each time. I discovered I had not dragged the existing version of APM to the Recycle bin and deleted it from the Recycle bin, before reinstalling APM. For some reason, the FTDI drivers will not appear if you reinstall over existing APM. After doing this one step, and WITHOUT reinstalling the driver, the required driver magically re-appeared. Bill, despite you choosing not to respond to my request on both sides of this gentleman’s, after careful consideration, I thought it proper to respond with what I found worked. A little disappointed since obviously you saw my requests but not even a peep back in my direction.

Hi there!

I’m facing the same issue, still unsolved. It’d be great if anyone could help.

I’m using APM Planner v2.0.27-rc1 on macOS Catalina v10.15.5. Drivers installation is unsuccessful, but could install those from FTDIchip. Yet, APM Planner performs the same.

The problem is that I can’t see any firmware options and no valid devices are found. See image below.

Any further suggestion?

Thank you so much!

There does indeed seem to be a com port problem with APM.P
I thought I would double check the situation and connected to Cube Black without issue.
But considering the issues appeared with the Install Firmware page I decided to update the Cube to the latest copter, and this is where it all went south.
You can see here that the com port was found and the install started but hung at 86%

Going back to the Flight data page and trying to connect generated an error
Screen Shot 2020-06-12 at 1.46.33 pm
which is not surprising as the firmware update function was probably still in effect but I did notice the port has changed from 1401 to just 01.
Upon closing the dialogues APM.P crashed.
On reopening and trying to connect I now get the spinning beach ball and APM.P hangs.
Screen Shot 2020-06-12 at 1.47.48 pm
Screen Shot 2020-06-12 at 1.57.02 pm

Now when I run APM.P I no longer get the vehicle icons in the top of the firmware page


Although it does recognise the Cube and I still get the com port appearing.

Update: I tried a Pixhawk 1 (3DR original) and I get an ‘unknown platform’ error.
The 1401 com port had reappeared.
Still no vehicle icons.

So I re-installed the firmware using Mission Planner into the Cube and plugged the Cube in again to APM.P
The icons re-appeared and the install went without a problem.
The port also stayed at 1401.

Hey there mboland,

I am having the same issue of not getting the vehicle icons. I am also running Catalina 10.15.5, but I am unclear as to the steps you took to resolve your issue. Would you mind expanding? I am running a pixhawk 2.4.8

Thanks!

I used Mission Planner on a PC to do the install.
It all seemed to work after that.

Not sure if they have fixed APM.P yet, but Catalina has real issues with com port drivers which I am experiencing with FTDI connections at the moment.

1 Like

FTDI driver 2.4.4 available to download by direct link:

https://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_4_4.dmg

The manufacturer send me that version.

They will update website soon.

1 Like

I have the FTDI 2.4.4 drivers installed on my Catilina system, but I am as well am not able to update Firmware/activate a new Cube Orange.

1 Like

That and the 2.2.4 driver worked for me–thanks!

Spoke too soon. Cube Orange shows up in the System info on OS X 10.15.6:

image

Tried connecting to cu.usbmodem1403 in APM, but no connection is available to upload the firmware.

Running on both 2.0.27-rc-1 and 2.0.28-rc-1.

Ok, so, for me on Catalina (10.15.6), APM Planner works but QGroundControl does NOT work. In QGC, the /dev/cu device is not shown in he dropdown list under the comm setup. QGC DOES work with bluetooth.

I run Catalina 10.15.4 and QGC works just fine with usbmodem.

When you refer to “usbmodem”, what exactly are you referring to? Is this part of the device name in Mac OS or a choice in the QGC dropdown menu or something else?

Well, no need to reply to my question. I took a look at Mission Planner on a windows (yuck) laptop and fell in love with it. So, despite me favoring Macs, I am going with a different platform for this application.

Servers by jDrones