FS_THR_ENABLE = 2 doesn´t work right


I just updates to Rover V4.2.3 from an older version. (and from black to orange)
With the older firmware I used FS_THR_ENABLE = 2, means, no throttle failsafe when in auto mission. With the new Firmware I set up the same, but it doesn´t work. When I shut off the transmitter, the mission aborts. Any hints or help?

Hi @3Denis,

I don’t think anything has changed with this feature so could you post an onboard log of this happening?

Thanks for your answer! I did a little testdrive. In the middle of WP1 and WP2 I shut off the transmitter, where the boat triggered RTL.
What is also new is the transmitter (Radiolink T8S instead of T8FB) and a Raspi Zero running a MAVlink connection via Wifi.



Hi @3Denis,

Thanks for the logs. I think what’s happening is that a failsafe has been setup in the receiver. When the transmitter and receiver lose contact the receiver is moving all the RC outputs to their middle position. This is change the vehicle into manual mode. Then when AP’s RC failsafe triggers it sees the vehicle is in manual and then triggers RTL.

I think the solution is to change the configuration of the receiver so when it loses contact with the transmitter it stops sending pulses and leaves the output at their last known value.

Hi @rmackay9,

you are so right! The T8S has a failsafe set. Actually I saw in the radiolink software that the channels move to middle, but didn´t had in mind that also CH5 is affected and switches to manual, before AP ignores the failsafe in auto.
As far as I can see, the failsafe can not be turned off at the T8S. Work around for now is, setting the failsafe for CH5 to low, which keeps AP in auto.

Thanks a lot!

1 Like