Frsky telemetry with Pixracer missing sensors except GPS

Hi, trying to configure telemetry with Frsky, when I try to detect them the only one I get from Pixracer is GPS, I get the receiver voltage and RSSI of course, and A2 values. Trying the same procedure with PX4 and I get full list of sensors, like main battery, vertical speed, ground speed. I set the serial 4 parameter on 10, as requested. Why can I get GPS values (that’s mean connection in well configurated) and not other ones? What parameter am I missing? Running 3.5.1. Arducopter and using Taranis X Q7 with X4R receiver.
In other words, why with PX4 frsky telemetry works “Out of the Box” and not with Ardupilot? How is it possible to read GPS values (that’s the proof that communication between Pixracer and Frsky works) and not the other values? (Heading, Vertical speed…)

Thanks, Chris

Try option 4 (Frsky Sport).

@dkemxr, thanks, the serial4 protocol was already set to 10, but same result.

Not sure I understand your reply. Setting serial4 protocol to 4 rather than 10 didn’t work either? This does work for me on the Taranis.

I mean this value was already set to 10. Communication seems ok, because I’m able to get GPS live values (coming from Pixracer) RSSI and receiver voltage from X4RSB receiver. When I first tried with PX4 firmware, I get all values like altitude, vspeed, main battery voltage, GPS, etc. Do you also have a Pixracer?

Yes, 2 of them. The one on a multirotor discovers the sensors shown below when the protocol is set to 4 (not 10).

1 Like

@dkemxr WOW!

What can I say, now I have 12 sensors discovered! Just putting parameter to 4! Thanks very much Dave! Do you know who to contact to update documentation? This documentation needs to be adapted for the Pixracer, anyway, thanks a lot!

Happy to help. There actually is mention of Pixracer in that guide but little information about option (10) Passthrough SmartPort telemetry.

I’ve tried it with Pixracer R14 running Arducopter, using FrSky X4RSB and worked well. But, when I try to use R9Slim receiver, it does not work. Does anyone know what could be?

By the way, from where is this GUI? I mean, what software are you using to see the telemetry parameters on computer?

I’m not sure what you are referring to. The telemetry screen in the previous post is in OpenTx Companion. This is a bit dated though. If you have a PixRacer and want telemetry on your Taranis this is the way to do that: