FrSKY Taranis X9D Plus and X8R Telemetry Lost Problem


I’m using FrSKY Taranis X9D Plus with X8R receiver. After resetting the transmitter, I have completed Stick calibration and configured Fail-safe.

I created a model for Fixed-wing and bonded X8R successfully.

But the problem is that now when I’m using the TX-RX, several times the TX announces that Critical range problem and Telemetry signal lost. After a matter of seconds, it will connect again.

This issue repeats again and again. I don’t know what and where I missed.

I cannot test my flight in this condition.

I’m new to FrSKY Taranis and X9D.

Anyone faced similar problem and If solved, please share the solution (troubleshoot or setting problem).

Is the tx and rx too close together? Have you tried them more than 2 or 3 meters apart?

I checked both. Same problem.

Is there any problem for doing so?
Even if I keep 3 meter distance, I faced the same problem.

Is there any configuration that I need to do after resetting the EEPROM or Taranis X9D plus??

As I said before, I did the stick calibration and set Receiver Failsafe.

I’m using SBUS and bound the X8R with D16 and Ch 1 to 16 setup.

Anything that I missed to do so??

Check your power supply/cable to the receiver

The problem solved automatically.