FrSky smartport telemetry

Hi, I’m having some kind of anomaly with the attempt to use frsky smartport telemetry.
I’m using pixhawk cube, frsky x8r receiver and taranis x9d+ transmitter. Original C&T cable.
I have tried it with lua and yaapu script, no telemetry data.
Wierd thing is, that I was able to discover gps sensor twice, but not anymore.
I’m using serial protocol 10, telem2 port
Also tried it with log_bitmask 0, nothing…
Have tried it inside and outside… no difference.
Also, got one error from taranis when I tried to open up lua script(only happened once)-

huuh anybody…? Have been messing with this thing for few days now…
Also tried with another cube… nothing better. Another cable, nothing better.
Am I doing something wrong? Maybe something with taranis itself?

Thank you!

As I remember the CT cable requires for a MavLink stream to convert it to FrSky telemetry data. But you’re providing it with FrSky telemetry data already (protocol 10) so the cable doesn’t support that. Try assigning the MavLink protocol to the telem port 2.

I use C&T Flight Deck. Your serial port protocol setting (10) is correct.

If you are getting script errors, its either caused by the version of OpenTX you are using, or the version of the C&T LUA scripts you are using.

What version of OpenTX are you using?
What version of Flight Deck are you using?

Does the radio still detect the RSSI and RxBat sensors?

NOTE: If you inadvertently connected the C&T cable backwards, it’s toast. BTDT…

I’m using opentx 2.2.2
I’m not using Flight Deck, Missionplanner instead with APM copter 3.5.7
Yes, the radio always keeps detecting RSSI and RXBat sensors.
There is no chance to connect the cable backwards.

make sure you set the serial port to frsky passthru telemetry, not just frsky telemetry. that caused me days of headaches.

Hei David!
That’s checked. protocol 10 is frsky passthru and 4 is telemetry

Little update- I removed the +5V cable between the C&T cable and X8R receiver. Now I’m again able to discover GPS sensor, and it also shows some values… So level up, but still if I open script, it shows “no telemetry data, check telemetry tem2”
Interesting is, that lua script shows RX percentage %(I’d assume that script is also working then?).

Hmm another update-
I changed the protocol to 4(FrSky Sport telemetry) which gave me alot new sensors to discover. But Luascript still says no telemetry data.
now I discovered these sensors:

Why the script still doesn’t work? anyone?

Ookey, case closed, reflashed 5th time my taranis with new SD card components and suddenly things started to play out.
Also Luapilot script can only be used with protocol 4(Frsky Sport telemetry) and yaapu only with protocol 10(Frsky passthrough telemetry).