Servers by jDrones

FrSky FPort support - testers wanted

I now noticed that everything is working good as long MissionPlanner is connected via USB ???

Working good with mission planner:
https://share.icloud.com/photos/0p6eEB-RA5MvK2ooaBQxVaUcQ

Not working without:
https://share.icloud.com/photos/09O8xe83niLHMgMumrHgrfIlw

Im helpless :frowning:

Oooooh it needs to be armed for the trottle failsafe to kick in… sorry guys nevermind.

Let me ask some assistance of community :slight_smile:
I have matek f405 std connected to r9mm: inverted fport connected to tx3 pin of fc
The settings are:
Latest build from master
SERIAL1_protocol = rcin
SERIAL1_options = 4 (or 164) doesn’t matter
Other options have no effect
As results I have rc control working
But in telemerty sensors of taranis I have only 3 them: two standard + gps.
Gps shows correct value.
How is it possible to have all sensors working?
Regards,

Changing brd_alt_config doesn’t have effect
Changing rc_option to everything except 0 makes nor control nor telemetry working
Having stable build not master makes telemetry not working at all

If you have 3 sensors with GPS than frsky passthrough telemetry is working.
The yaapu script or flightdeck should be working with your setup!

You don’t see other sensons because fport does not support repurposed frsky telemetry i.e. serial_protocol=4.

1 Like

Wow!
It was minor issue with openTx on my Taranis.
Now fport on r9mm and Matek STD working well!

Thanks in advance!

My config is:
Master firmware
R9mm inverted fport connected to tx3
SERIAL1_protocol = rcin
SERIAL1_options = 4

Btw, yaapu scrip looks really sexy

1 Like

I can confirm FPort is working with Matek F405-CTR using a FrSky XSR receiver modified for non-inverted FPort as at https://www.flitetest.com/articles/frsky-xsr-fport-modificationss, with the non-inverted fport (formerly CPPM) pin connected to TX4 on the F405-CTR using the following config:

SERIAL2_PROTOCOL = 23 (sets RC Input)
SERIAL2_OPTIONS = 4 (set Half Duplex)
SERIAL2_BAUD = 115 (sets 115200 baud)

Works great with OpenTX and yaapu telemetry.

Just moved my omnibus F4 Pro over to f.port with R9MM. Control AND telemetry work (with Yaapu).

Version: Plane latest (b6ef76a1 2020-01-12-00:01)
Board: Omnibus F4 Pro V2
Receiver: FrSky R9 MM (Connected through the “inverted s.port” labeled pin (which is uninverted))
Transmitter: Jumper T16 Pro with R9M 2018 edition
Serial Port 1 (powered through the 4 pin plug)

SERIAL1_PROTOCOL = 23
SERIAL1_OPTIONS=7

1 Like

I have tested it on Matek F765 with R9Slim+. RC is working fine but Telemetry is not working at all. Tried various settings but no luck. Telemetry works fine in INav with same wiring. Need help please.

1 Like

All,
I would want to contribute and test F.Port, but I can do only as a bench test / function test, not flying yet with my build.

I am on Pixhawk4 - Copter 4.0.1-rc3 - Frsky RXSR ACCESS/EU - Taranis X9dSE2019, Hexa-X based on DJI F550.
With a fully functional S.bus, and S.port and Frsky passtrough Telemetry fully functional on Serial-4 and Yaapu9 on my Taranis.

I can flash my RXSR to ACCESS F.port, and give it a try, but I am not familiar with the process how to get the specific compiled code into my build. Or is it already embedded in 4.0.1-rc3 - Pixhawk4 ?

tnx
John

It’s not in the betas yet, so to test you’ll need to use a dev firmware (aka “latest”). https://firmware.ardupilot.org/Copter/latest/Pixhawk4/arducopter.apj

Tnx James, crystal clear. Will give it a shot next weekend.
Grtz
John

Hi ,
could you fix the problem ? Because i have the same!

post a tlog or onboard log (*.bin file) and also tell us what uart pin you are connected on. I’ll check your parameters

I have it fixed the Telemetry.

R9 Slim +
R9M 2019
X9D +
F765 Wing
AP 4.1.0

BRD_ALT_CONFIG,1
SERIAL7_BAUD,115
SERIAL7_OPTIONS,7
SERIAL7_PROTOCOL,23
RC_OPTIONS,0
RSSI_TYPE=3

And der F-port to TX6-Pin

Can confirm the same thing - 765 wing.

RC_OPTIONS,8 - No telemetry, only control
RC_OPTION,0 - Its all working… very cool :slight_smile:

I can confirm the following working (RC and Telemetry using Yaapu9 Lua on Taranis) :

Pixhawk4 + Frsky RXSR (ACCESS - F.port firmware)
The RXSR is straight wired from S.port pin to Tx on Serial4 (no juggling around with non-inversion pins on receiver). SerialX_OPTIONS=7 does the trick here.

RC_OPTIONS 8
RSSI_TYPE 3
SERIAL4_OPTIONS 7
SERIAL4_PROTOCOL 23

I still have the problem that Telemetry does not recover after RSSI reaching low value (not determined the threshold yet). When signal strength recovered, only the receiver based telemetry (RSSI and RxBT) are coming back up. This was also the case in S.Bus + Frsky passtrhough, not related to this F.port implementation.

Let’s have it ! One wire less !

grtz
John

So does the fport work on pixhawk? I do not, I am very surprised at who works, share details

Hi Ilya,
Details of my setup provided in my post. Pixhawk4.
Let me know what more dtails you´d like.
br
John

It does not work for me. I connected the wire from Sport to serial 4. Plus and minus set the settings. Is this enough?

no control no telemetry.
I checked betaflight everything works.

Servers by jDrones