Servers by jDrones

FrSky FPort support - testers wanted

I dont think it is possible to interface S.Port sensors to ardupilot. Stick to the documentation about which sensors can be used

https://ardupilot.org/plane/docs/common-serial-options.html

No 4 says Frsky smart port ?

yes, that makes the FC behave like a sensor on the Rc-Recivers s.port bus

Hi, this is not supported ATM, ardupilot cannot be a master on the SPort bus, a receiver is always needed. FRSky sensor can be chained on the sport bus along ardupilot but ardupilot cannot use them, like @Simon_Exner said ArduPilot acts as a slave.

Thanks for confirming!

As I am using an r9m which has the same pin for f port and s port , does this now mean I cant chain the sensors as I am using F port ?

So I need to go back to the old way of Sbus and s port ?

Thanks

Yes, fport does not support chaining. Fport2 does

That’s ACCESS only Rx’s right?

1 Like

Yes I am on Fport 1 and ACCST.

Thanks for the help.

Sorry, created a new post, should’ve put it here…

I am in the middle of a new build and was trying to give F>Port a go. So, I have r-xsr flashed with fport accst firmware, updated my Taranis with latest OpenTX, flashed internal module, hooked it all up according to instructions:
BRD_ALT_CONFIG=1
SERIAL7_PROTOCOL=23
SERIAL7_OPTIONS=15
RC_OPTIONS=8 (did not work at all without it)
RSSI_TYPE=3

The thing is, I can’t get telemetry consistent. I can discover GPS sensor for a sec, as well as YAAPU script responds for a sec, then nothing. If I hold bind button on RX, it switches to whatever other mode and I lose control (no movement reported on TX calibration page) but telemetry goes for a second again and stops. I hold bind button again, blue light comes on on rx, I regain control, telemetry turns on again but again only for a second or so.
Using Arduplane 4.1 dev (latest)

So, I have reverted back to SBUS and smart port telemetry, and it works fine.

Is FPort broken or am I missing something here?

I have Fport working on a Matek H743 with the same configuration you have except for RC_OPTIONS (not needed). It’s an R9mm-OTA with ACCST Fport but that shouldn’t make any difference. Another with a Kakute F7 Mini with similar config. So, not broken. Using Arducopter 4.1.0-dev.

Hello Tridge,

I heard F405wing can be Fport without inverter if there is invert signal output from the receiver. it is true? how can i set it up? my receiver are R9MM and R9slim+

@xixijoe

You will have to use “inverted S port” pad of R9MM to make FPort work with F4 boards without inverter.

I followed the Fport setup. but it did not work. I just could not figure out what did I miss. neither F765wing and F405wing. is it possible to have video tutorial to look at? or something that i can refer to one step by another? thank you for your help

@Anton_Khrapov
I had a similar situation where i spent full 2 weekend days and ended up finding a simple issue. It was RSSI. Yaapu script will not work if there is no RSSI in the mavlink stream(assuming you are using Mav2PT converter).

Just to try, setup RSSI as 1 (analog) even if you don’t have anything connected to analog pin. Just a test and see if you get Yaapu script working.

@xixijoe

Try
SERIAL1_PROTOCOL = 23
SERIAL1_OPTIONS=7

Also make sure your R9mm receiver is flashed with FPORT firmware.

1 Like

The most important step :slight_smile:

Which FC you mean?

For the F405wing here is what I did

F4 based autopilots using an “inverted FPort” output from the receiver can connect it to any UART’s TX pin with the configuration:

SERIAL7_PROTOCOL =23
SERIAL7_OPTIONS = 4 (Half Duplex)
RSSI_TYPE =3
RC_OPTIONS = 8 (either =0 tried both)
BRD_ALT_CONFIG =1
Uart1 TX to the r9mm receiver

For the F765wing

BRD_ALT_CONFIG =1
SERIAL7_PROTOCOL =23
SERIAL7_OPTIONS =15
RC_OPTIONS =8 (either =0 tried both)
RSSI_TYPE =3
Uart6 TX to the r9slim+ receiver

neither of the FC works for me. I don;'t know what I miss.

I meant F405 board.One more thing.You must run the latest version of Arduplane.Not sure if Fport has made to the stable yet.

I used SERIALxx_OPTIONS=7 on my omnibus F4 board thou.

Try serialxx options=7, protocol=23, rssi_type=3
and make sure that no other uart has serialiN_protocol=23 or 10

Also make sure you connect signal wire from r9mm to the TX pin of your FC. Serial options 7 is to swap Tx with Rx I think.

Make sure that no other serial is set to S.Port or something alike.

Servers by jDrones