From 3.6 to 4.0.3 less precision in flight

We observed the copter being a lot less precise in automode expecially in altitude when going from 3.6 to 4.0.3.
We set gps as primary and while in rtk altitude goes up and down a meter or so, 3.6.11 didn’t do it. Strange thing is that while the copter goes up and down, the gps reports the changes in altitude correctly, so it is not the gps telling the fc to change altitude. Test done with copter flying 5 meters of the ground in RTK with gps as primary source of altitude (option 2)
Also xy position while flying slowly is a lot less precise, it goes almost 1 meter side to side, while 3.6.11 was spot on, same everything except we updated to 4.0.3, speed in auto is 0,5 m/s.
We did not do another auto tune after updating, we just updated values with the new alt+a mp plugin.
It looks like 4.0.3 is a lot less strict while in auto mode.
@Leonardthall maybe you can help us a little here.

You are probably better off using 4.0.4-rc2, it has EKF fixes, parameter reset fixes, and compass fixes

You think my precision problems could be caused by stuff fixed in 4.0.4-rc2??

There has been nothing changed in the position controller. There are some additional settings in the attitude controller that may have an impact on the attitude tune. Mainly the FLTT filter. But if you set that to zero and still see the same issues then it isn’t that.

Sorry I can’t suggest anything here and we have not heard similar reports. I have not seen any issues on any of my aircraft also.

Thank you Leonard, i guess i am at a loss, can’t go back to 3.6.11 because i need rcoverrides above ch8 but 4.0.3 is so much less precise that we are not able to work. Quad just wanders around course and altitude by more than a meter, it was centimeters on 3.6.11
Do you think an autotune would help? We are stil on 3.6.11 pids.

Can you reload 3.6.11 and do a back to back mission on 3.6 then reload 4.0.3 and do it again?

I might be able to tell you what has changed in the controllers then.

If you are able to do it make sure you have the following logging enabled for both flights.

Hello @Leonardthall , first of all thank you for your interest. The problem in going back to 3.6.11 is that i changed all my ground software to use all channels above ch8 so it is extremely difficult for me to fly with that firmware now.
If it is of any help i can activate all the logs you suggest and send a bin on 4.0.4-rc2.
Yesterday i tried to raise some P gains of position and velocity xy in psc and it seemed a bit better but on third flight it went into a semi out of control swing wich i could stop only going into stabilize mode. Strange enough once it did it once i could never enter loiter again because it would start to oscillate again, had to land in stabilize and lowet those psc gains and all was good.
To describe the precision problem a little better, if i put the quad in loiter at 5 meters, and watch at logs after it correctly shows the gps altitude in rtk (my primary altitude sensor) at 5 and the desired at 5 meters correctly, but the quad stays at 4,7-4,8 with 1 meter up and down, wich is very strange in rtk.
This same copter has been used in the last year on 3.6.11 to take about 2 million pics (actually closer to 2,5 millions) of serial on photovoltaic panels and has been very very precise in altitude because our camera has a 40cm dept of field and it never goes out of focus.
This been said, since we switched to 4.0.3 and now to 4.0.4-rc2 altitude has become a nightmare, even with no wind the copter is absolutely unable to keep 3.6.11 precision.
Is there any chance that during the upgrade some parameter is not set correctly in your opinion?
Don’t know if i said it before but the copter is a 25kg : quad
Ublox F9 rtk gps.
X8 hobbywing motors
30 inches props
12 s
Cube black on kore board

Thank you again.

If you can provide logs showing the problem that would be good. Also a video would be helpful.

@Leonardthall Here is a log of 4.0.4-rc2 during a flight over a panel.
If you have time please take a generic look to see if you can see anything badly bad in pids and conf.

Thanks in advance.

This flight doesn’t appear to have the logging parameters I suggested.

It is very frustrating when I am very busy and make time to help someone and they can’t be bothered to provide the information I asked for.

Leonard we tried but if i enable all those settings i get a logging error.
Maybe i should get an orange cube.

You may not be using a good SD card. I replace the standard card with a class 10 or faster card. That may solve your problems.

Ok thanks will try.