Frametype only copters?

I am trying to set up my first rover using Pixhawk4 and Mission Planner. I have ArduRover V4.1.0. I am running into some other first time setup steering and throttle issues, but I think those are unrelated?
Anyways my main question here is under Setup, Mandatory Hardware, Frame Type; all I see are different quadcopters. Did I mess a setup step somewhere or is this normal? Am I supposed to have rover selected somewhere else?

Any advice is appreciated!

All you have to set is the FRAME_CLASS parameter in the Full Parameter List. Rover, Boat or Balance Bot. Rover is default, it’s probably already set.

Oh, actually it wasn’t. It was set to Undefined. I switched it to rover though but im still having my other issues. I cannot get my motor test to work for steering or throttle. I can see the positions moving in Radio Calibration, but in Servo Output I can only move ground steering in 1. Throttle never moves in 3. I can switch each to RCIN1 and RCIN 3 and see both move, but motor test still doesn’t work. Any ideas? (I have steering set to output channel 1 in my tx and Throttle is channel 3)


Got a safety switch?

Yeah, it is disabled I believe? At least I am able to arm and disarm the vehicle. Wait, actually I am able to arm and disarm after I unselect ‘RC Channels’ in ARMING_CHECK parameter. If I left it checked I kept getting “PreArm: Throttle Radio min too high” and I googled and googled and couldn’t figure out that that meant. I wasnt even sure what that check was even doing. Could that be related?

It’s disabled if you have brd_safetyenable set to 0. Mid throttle should be ~1500µs. The radio calibration screen shows 1705. It won’t arm if it’s that far out of range. If it did the Rover would take off. Perform a radio calibration with the throttle at mid stick when complete.

Okay, actually just now I had an inspiration as to what that message meant about throttle radio min too high meant. Because of the rover I am using is faster than I want normally, especially in reverse, I have my transmitter limit the max reverse. When I calibrated the radio in setup, it must not have liked that the throttle radio minimum was too high. Makes sense now and system arms and disarms normally with all checks performed. The reason my throttle was at 1705 in the screen shot because that is what I was holding at the time, trying to show I can move it according to that screen in mission planner.

Looking into safety switch now. I assume that if I can arm the rover the safety switch is disabled? or is that not the case? I have BRD_SAFETYENABLE param set to 1, but the software just says what the natural state is as startup?

I think I can confirm my safety switch is off. I can holding the switch on the gps unit and get the hardware safety switch message in mission planner. Either way, motor test still does not work.

I changed brd_safetyenable to 0. Reset the autopilot and still the same issue. I can tell now in servo output the Throttle moves once I am disarmed, but I still get no movement for either steering or motor in motor test.

AHA! I was the idiot. It was a wiring issue on my end. I am using the pixhawk 4 and accompanying power management board and turns out I needed to use the I/O PWN OUT on the Pixhawk and take that to FMU/PWM IN on the power management board. Its definitely confusing as there is also a FMU/PWM OUT on the Pixhawk and a I/O PWM IN on the board. I got desperate and just started switching things trying to figure out what was going on. Thank you for the help though figuring out my other issues!

1 Like