Frame Change

The problem I am trying to change to a hex frame type from Quad X on a APM2.6. i have updated the Firmware for the hex copter but when i get to step 4 pick your frame type in the wizard it only shows X H Y6B and T . I have tried it on my other computer and I’m getting the same thing also tied installing firmware for other frame types to see if it would change anything and still the same, Any Ideas what i might be doing wrong ?
Thanks for any help in advance!!

Hello I was told the best way to fix this problem would be to go into CLI and do a factory reset by clearing the EEPROM.and then setup. The problem is that when in CLI and click connect all i get is scrolling text down the page… not the setup test erase etc like my other boards. the firmware is 3.2.1 Is there another way i can clear the EEPROM or fix this problem? … t.jpg?dl=0

The cli was removed from ver 3.2 onwards for the apm as there was no space left for it.
I can’t see an option on mission planner but an easy way is to upload arduplane, then when that’s finished uploading upload arducopter again.

Switching between the firmware types forces an eeprom erase

Thank you for the information Its seems it worked out well …after changing back from Arduplane to Arducopter3.2hexa I did a complete new setup … Now when I download data log files now it shows HEXAROTOR in the log directory also all 6 motors arm now ! Cant wait to try new Tarot680 and weather to warm up from this -35* the last couple weeks. :frowning:
Thanks Again MarkM