Follow Me Gimbal Tilt

I’ve been flying my new Tarot 680 Pro build since Christmas without any real problems including the Tarot 2D gimbal. I have the Taranis configured with channel 8 as the LS pot going to RC9 on the Pixhawk to control tilt…this works very well. I had to tweak the max/min PWM values slightly in MP from what the instructions show to get nadir and straight forward however.

I attempted follow me yesterday and today for the first time connected to DroidPlannter 2 on my Galaxy S5 with good GPS coverage. It seemed to work well as far as having the hex follow me, however the video from the GoPro for the most part only caught my feet…it was always pointed to low. Today I adjusted the PWM values in MP so that the camera wasn’t quite capable of nadir and it mostly captured me from the waist down as I was walking. I was set on 15m leash at 15m elevation in a level field.

Is there something that I’m missing, perhaps another setting to adjust the calculations for how to tilt the gimbal? I thought that configuring it in MP so the min PWM corresponded to -90 (nadir) and the max PWM corresponded to straight ahead level would work for the pixhawk to triangulate the tilt but something seems to be off. Is there something in the logs to show what it was trying to achieve with the tilt?


I haven’t tried the follow me mode yet, but my gimbal is set so that a pwm of 1500 has it looking dead ahead with max and min pwm being 90deg up and down.

Maybe give that a try?

I had to use the Gimbal dongle and set the parameters in Tilt setting for angle limits from min 0, max -135 to min 0, and max -90 on my Tarot Gimbal.
Second I had to change the MNT_ANGMAX_TIL from -45 to 0 and the MNT_ANGMIN_TIL from 45 to -90.


Thank you for the replies. I had both my gimbal and Pixhawk configured exactly as the instructions on show, which is slightly different from what is being suggested. I made some adjustments today but it was to late to fly so I will try them out tomorrow.

I was finally able to get some time to test this out and it does seem to work. I did a full reset and reload of the firmware on the Pixhawk, Tarot, and Taranis Plus and re-configured everything according to the instructions. I can’t say exactly what fixed the problem.