Servers by jDrones

Follow me at QGroundControl

(Armen Bogush) #1

How to use follow me mode? I can’t see this mode. Updated PX4 to latest Copter 3.6.10
I don’t see followme mode.

(Dpsoftware) #2

This don’t depend about copter firmware , Qgroundcontrol development software is not update with the last filght modes. Missing are Flowhold and Follow
The riight place to send the request is https://discuss.px4.io/

(Armen Bogush) #3

Haha, they say right place is here (https://discuss.px4.io/t/qgroundcontrol-on-android-and-follow-me-mode/12377/2)
PS: this was an idea that QGC use some new protocol to send gps data, not suppored in old firmware.
But anyway, In MissionPlanner it’s possible to select follow mode. But MP don’t work on Android.

Here is modes from MP:
2019-08-12_15-57-55

(Dpsoftware) #4

Uhmm… i don’t know about the follow mode , but sure QGC need to send gps data. But I don’t understand why this must be a problem solved with the firmware. FlowHold is not added and is a simple flight modes. Unfortunately tower , the old official android app is not supported anymore.

(Armen Bogush) #5

I’m not sure it may be solved with firmware, i’m looking for any solution. I updated to 3.6 as it appear to have improved Loiter mode as well. and just a possible solution for followme. But it did not help. So looking for any ideas how to enable this mode.

Flying modes must not depend on ground station, i think, but QGC don’t show 2 last modes, somewhy.
If anybody is using QGC, can show this option in interface? Maybe they removed this mode in last releases? But i see some options for this mode…

(Dave) #6

QGC will show Follow me mode if the firmware on the craft is the PX4 flight stack. Arducopter does not have a Follow Me Mode.

(Armen Bogush) #7

Are you sure? it was just said that follow me mode is implemented in ground station by means of guided mode. and I’ve seen guys used followme mode with APM 2.5, for example (https://www.youtube.com/watch?v=s1ksqQXxCWQ) but droidplanner or tower (currently unavailable)

(Dave) #8

Sure about what? Arducopter does not have a Follow me flight mode PX4 does. As I said in the other thread and you repeated here it’s implemented thru guided mode via the ground station and if you are running Arducopter the Ground Station available to do this is Mission Planner.

(DonLakeFlyer) #9

QGC supports Follow Me as described by the Mavlink spec. It does not support Follow Me supported by ArduPilot specific ground station only implementation or the current ArduPilot implementation which is not Mavlink generic.