Flywoo M10 GPS modules

Have you guys seen these $20 M10 GPS modules from Flywoo? The “Pro” version has a compass, the other 2 are ridiculously tiny:


I have all three of the models. And I really like all of them just getting around to making some mounts for my AOS 7 frames. I have had them hooked up in my home and got good reception and sats. As @dkemxr says for the price you pay they are pretty unbeatable. Do please ignore the fact they cannot spell pro very well on the pro one hahaha the sticker I have says RPO hahaha!!!

I ordered one to try out. I have a bunch of the Matek M8Q units. They work “OK”.

Looks like they have come out with a new mini that also supports compass. I have not used this one yet but I have thrown 20 dollars at worse things before hahah

I have some of the “Pro” laying around, but could not test them outside in the Rover.
On the bench they look OK, like the M9N.
My intention was to use them in my “not so serious” rover toys, like the 3D-printed tractor. Just to make the rover a bit more complete, even it will probably never do autonomous missions.

Not sure, if they have a backup battery (or gold cap) under the hood.
Or if they do a cold start every time.

In case they perform well, it might be worth to try them in a two-GPS configuration.
In another Rover I have quite good results with a two-M9N setup.

I’ve just been playing with the GM10 pro V3 and although it seems to be working, the ppm led is flashing, witch I understand to mean it’s getting satellites, but I can’t see in mission planner!
I’ve tried the default baud rate, and most others, checked that I’ve got the right serial port and the tx goes to rx!, it’s attached to Pixhawk 1
Any clues?

How long did you let it sit and where you inside a building? When you initially fire them up it will take a bit of time to configure everything after that it should find sats faster.

I’ll connect it up to a Pixhawk I have on the bench and check it out.

Works great. 23 Sats in 1 minute, indoors. Not much to go wrong here, the default parameters work if it’s connected to the GPS port.

28 Sats and an Hdop of 0.52 now. Indoors… So far this cheap module seems to perform well.

Thanks for the reply’s Dave.
It was on for most of the day! (irrelevant but the compass works!)
The defaults on sat type is 7, but I tried most combinations. I live in South Australia.
I second guessed myself and even swapped the rx tx lines, no change.
One thought just occurred. The FC is an old Pixhawk 1, it won’t update to the latest firmware as it’s a discontinued version, update defaults to the last available, is this a possibility? I was under the impression that NMEA streams, etc, were universal but I have little experience with GPS systems just trying to learn.
Primary GPS is a BN 880, works well, Sat count 16, HDOP 0.74


Are these right?
The default baud is 115?
The LED is flashing at 1Sec?
I’m using Serial RX-TX 5?

EDIT 2!!!1
Solved, why???how???
Changed serial to RX-TX 4 all good.
SAT count2 25 HDOP2 0.65
Sat Blend Count 31.

I’m impressed and this in the house!

mission planner 2
And the GPS trail, after 5 minutes, if hardly drifted and again inside a room with lots of RF noise!