Flying wing crash in auto mode switching to loiter

My plane crashed in auto mode when i was switching to loiter foe no real reason. please see log.

Is anyone able to take a look at this?

I’ll take a look at your flight, thanks for posting a log.

Thank you. I couldn’t make any sense of what happened.

The reason it crashed is there was a bug in the EKF2 attitude estimate related to flying without a compass. Your aircraft had MAG_ENABLE=0 which disabled the compass. In previous releases this was fine, but in the current stable release it has a bug where large gyro bias errors can buildup on the ground which can lead to bad attitude estimate and a crash.
It has already been fixed in master ready for the next release. I will post a warning on the release announcement blog post.
Sorry for the crash!

Thank you for looking at the log.

Gents, is there any chance in getting a plane 3.5.3 release that fixes the bug. The internal compass never works proper since its in the middle of all the electronics, so I have to have it disabled.

@Tridge thx for looking at the log.

@Jcooper21 I have some follow up observations

  • Does your GPS have a compass in it? Most of them do.
  • Your mission shows a takeoff of min 35 degree pitch then it climbs out at 45 degs. That is extreme but seems to handle the steep climb. Your aircraft is not able to achieve the 35deg until halfway through the takeoff when the airspeed gets high enough. I suggest lowering that so there’s better control during the first part of takeoff to gain some airspeed.
  • Your landing mission has a 90 degree turn at 45m above the ground. Does that work OK? How are your landings? I love seeing people doing auto landings, wish more people did them!


  1. Yes the GPS has a calibrated compass in it. The onboard is disabled.

  2. Will change the take off down to 30 degrees and see how that goes. I like steep take offs.

  3. Landings work great it just sucks I have to always drop a do start land command and try to build a landing sequence in mission planner when planning a survey and it’s a mess of waypoints. Plus you can hardly see the screen in the sun. As for the turns those work fine it just overshoots the corner then comes back in on its path.

Here’s your takeoff.

That’s not bad is it?

Ideally, you want your Roll/Pitch to match your NavRoll/NavPitch. That means the plane is wanting to do something and then is physically doing it. From your log, the first 1/3 of the takeoff, where you’re flying with an underspeed, you’re trying to pitch up much higher than it’s able to do and your motor is powering through it. It’s best to have the autopilot to be under control of the aircraft at all times instead of giving it extreme unreachable commands and let the physics of the aircraft limit you. That’s how you stall.

thanks for the advise. i will reduce the take off pitch to below 35 degrees for sure.

If you have an airspeed sensor, why not just set the takeoff to 10 or 15 degrees? It will pitch far beyond that to maintain trim speed, but not prematurely.

i did not know tgat. i will lower it more then. thank you

Even when the mission take off pitch is set to 20 degrees the plane does the same thing. It’s like it’s not respecting that parameter which I thought was max take off pitch. On take off the plane should not be going to it’s max pitch value which I have set at 45 degrees. Is this a software bug?

It’s min takeoff pitch, not max

How do I set max take off pitch?

It would be limited by LIM_PITCH_MAX

That also limits fbw pitch which is not really ideally for turning with a flying wing. It also limits pitch in FBWA which is not good either .