Pixhawk, mounted on Quadframes hexa, fpv flight.
Hexa had been flown before and Loiter/Alt Hold/Stab worked fine.
Tried Sport mode on this flight, as indicated by the logs, then back to stab, all seemed well until I engaged Alt Hold to take off my goggles and then I noticed the Hexa increased throttle and flew off in a very determined manner.
I tried to switch back to Stab mode but it resulted in a crash.
You can clearly hear the motors rev up.
I really dont see anything in the logs but I am not expert at log files
Skip to 5 mins

After looking at the logs, its possible, I dumb thumbed it, maybe someone can see if I gave it full throttle and caused the roll.

Hi, I had a look…

Generally, I don’t see any system failure that led to this crash. For the most part, the copter was obeying your pitch and roll inputs, at least as far as the logs show. The tuning is actually not great, as there are minor errors in the desired and achieved angles. But nothing that likely led to the crash.

You did indeed give it plenty of throttle, and it was climbing in response to that. Since you were asking for a fast climb rate, while pitching it heavily, that resulted in it achieving a high horizontal speed. Your motors appear to have a thrust imbalance, but I can’t see any particular pattern (it’s not obviously a CG problem, appears to be a random imbalance?)

I can’t see any obvious problems that led to the crash.

The weird thing is though, that the angles recorded in the log do not seem to match the angles visible in the video, via the landing gear. At one point it appears to be rolled over 90°, but that is not shown in the logs at all. In fact, the log appears to stop while it’s still in the air. Your Vcc doesn’t indicate any electrical problem. So why did it just stop?

You vibrations are generally OK, except for at some points, particularly when your velocity is high. Some people don’t think propeller disymmetry of lift is a real problem on multicopters, but your logs are a great example of it. It’s possible that at the high speeds, the vibration was enough to throw off the attitude estimate, but it’s impossible to say.

After interviewing the other pilots who where present and watching my flight via Minimosd on a TV setup, they claim to have heard a beeping just before I felt I had no control ( take with a pinch of salt).
I was running Pixhawk off a BEC as the cables supplied are to short for the PM to reach the battery.
Gimbal is powered by its own pack and not connected in any way.
Radio is a Taranis, no telemetry warnings, my helper removed my goggles, so me knocking a switch or sticks is unlikely.
Flight pack 4s still has 3.75v per cell, ESC grounds are connected, other than osd nothing else run of the Pix except supplied gps.

Thanks for looking, the thing that has me puzzled is the speed.
It was in front of me, helper takes glasses off for me as it was a bit unstable to land fpv (tuning I know), I look up to see it flying off, oh crap, I probably pulled back as a reaction, really was moving fast, at the point that I did not think it would come back I commanded a right roll and low throttle to crash it, which it did, took us several minutes to reach it, motors where not running then.
Unfortunately the dvr decided that that flight was one not to record or we would have minim video as well.
I guess I should have setup a land switch, live and learn.

Is it possible to disarm it in the air via the sticks, could I have done that?
I will go over the thrust issues when parts arrive, 3 legs at least lol, could be worse.

I found this log file…brownout at 12m?

Log File C:/Program Files (x86)/Mission Planner/logs/2014-06-08 14-07-07 4.log
Size (kb) 2668.0
No of lines 38883
Duration 0:04:20
Vehicletype ArduCopter
Firmware Version V3.1.4
Firmware Hash 61c7c067
Hardware Type PX4
Free Mem 65535
Skipped Lines 1

Test: Brownout = FAIL - Truncated Log? Ends while armed at altitude 12.55m
Test: Compass = PASS - mag_field interference within limits (17.02%)

Test: Dupe Log Data = PASS -
Test: Empty = PASS -
Test: Event/Failsafe = PASS -
Test: GPS = PASS -
Test: Parameters = PASS -
Test: PM = PASS -
Test: Pitch/Roll = PASS -
Test: Underpowered = PASS -
Test: VCC = PASS -

Could you have been disoriented? You say you pulled back, but it shows that you pushed the nose down (forward). It very clearly shows your stick input is pushing it forward. It’s a bit confusing though, was the gimbal pointing backwards?

Could your BEC have shut down due to low volts? You say you were on 4S, and 3.75V/cell, but the battery voltage would be lower at full throttle. What is the minimum voltage on the BEC? I don’t think this is likely as most BECs will go down to 9V, but just in case.

It does look like it shut down midair. I just don’t see any reason why.

It is possible to disarm it in air, but the logged stick inputs don’t support that.

I do wonder if the vibrations borked the AHRS and the reported angles were off. That could lead to the loss of control. How is it mounted? Like I said, the vibes look OK, except for when you’re at high speeds, they get a little heavy.

Yep, that’s exactly what I’m seeing.

But these look like two separate issues. I can’t see any connection to the reported loss of control and the brownout. The Vcc looks fine all the way through.

Disorientation is possible, it was pointing at me as goggles came off and flew over my head so i assumed pulling back was correct,kinda hard with hexas to tell, gimbal is forward facing…not a single prop was busted, 3 rear arms busted off so it hit on its back end, weird.
Bec min voltage is 6.6v
Mounted on stock foam on a plate also mouned with 3m gel tape as I would mount a fbl controller on a heli.
My helper was first on scene and had pulled the plug so I dont know if it was still armed.
I am leaning towards a brownout caused by me flying a bit long and giving it power, with no power unit to warn me, what do you think?
Trust in the unit is the issue, dont know how you prove it!

Well thanks to the help from Rob.
I have come to the conclusion that I goofed up and got my direction wrong after taking off my goggles so it was compounded by me thinking I was bring it back instead of flying away.
Only question is why did the logs stop in flight?
Rebuilding in progress.