Fly Away after switching from Auto to Stabilize


Had a major flyaway and crash today - AC 3.1.5. Copter was completing a land waypoint in an auto mission, and I switched to stabilize. As soon as I switched to stabilize the copter pitched forward hard.

I actually left it for a second or two to try to understand what was happening, but it just seemed intent on pitching forward. I tried to correct, but the pitch was not responding, Luckily the throttle seemed to respond, and I cut it, as the copter was heading for the road at car level.

I took a look at the log, Just after the mode switch (line 15359) the pitch seems to drop fast with no associated pitchin.

Anyone have any ideas.

Its a Hexacopter that hovers at about 20-25%

Would a negative altitude reading cause a fly away when switching from auto to stabilize?

Negative just means to the left in the case of roll, or down/forward in the case of pitch

My alt-ititude was negative not one of the att-itdude numbers


Didn’t get much of a response in the 3.1 section, so trying here.

I had a fly away and bad crash after I switched from Auto to Stabilize. I’ve looked through the logs, and can’t work out what happened. Roll and Pitch seem to diverge from Rollin and Pitchin as soon as the mode is changed to stabilize.

The only things I notice of interest are that the ALTitude was negative at the time and also this is an over powered hexacopter, so throttle would have been very low.

This same copter with smaller motors and props did a similar thing a few months ago but just from stabilize. Could there be a hardware fault with the APM unit itself? Faulty accelerometers, gyros?

Any ideas would be greatly appreciated as I am very nervous about flying this copter again once I get it fixed. Problems happen after line 15359.


Would a ESC sync issue cause a huge jump in current draw?

On looking at the tlog, there seems to be a huge jump in current draw just as I switch from auto to stabilize. This copter usually hovers at around 18 amps, and the current jumps to about 75 amps. It probably jumps even higher but is at the limit of the current sensor. The throttle is very low at this point.

Any insight would be helpful.



Problem : copter pitched and rolled and accelerated in stabilize mode without pitchin or rollin and with minimal throttle input. Operator was about 5 meters away, didn’t panic, left alone for a second or two, then tried to control, then had to cut throttle, crash.

Hardware information - Tarot FY680 hexacopter, SunnySky V3508 700KV motors, RangeVideo Slimeline ESCs (BLHeli), 3DR APM 2.5 with internal compass disabled, 3DR LEA-6H GPS, 3DR Voltage and current monitor, 3DR 915 Telemetry radios, 13" Carbon Fiber props, 9X radio and receiver. Overpowered, hovers at just over 20%.

Software & Setup : Arducopter 3.1.5, Erased, Compass Calibration, Accel Calibration, Radio Calibration, Compass MOT (7%)

Dataflash and Telemetry log attached

Sorry for the delay. Motor 3 probably failed, and given the overpoweredness, minimum throttle was possibly not low enough to allow the copter to stay level without ascending.

Look at the SERVO_OUTPUT_RAW message in your tlog - motor 3 goes to upper limit, motor 4 (opposite motor) goes to lower limit.