Flips on takeoff

So I have been building my drone since the past 3 days now. Everyday my day ends with the drone flip on take of.

My motors spin well
My frame was for the racing drone first.
Now I took a bigger frame thinking it will be a balnce issue.

I flashed the firmware. Changed the frame.
Calibratied my ecm
Did the compass calibration, tried different modes and what not

( I did not attach an external compass)

Live calibration has not been collecting points and I dont even see the screne where It shows point collection.

I really did alot of trials and error and still not able to find any sucess. Could you tell me a best solution to this.

Really appreciate if you’ll could help me out soon

Do the motors run in the correct order and direction when testing with Mission Planners Motor Test function?

I have physcially checked the motor direction. I don’t see the motor test function on my mission planner. Is it because I use the mac osx?

Setup>Optional Hardware>Motor Test

Make sure you understand the order the test is run in when you press the A-D (assuming a quad) buttons. Props off.

Are you really running Copter 3.6? If so why not update to current Stable?

So to be hoesnt this is my first build.

Is copter 3.6 a version?

APM planner 2.0 I have been using. And have updated the firmware.to the latest.

Where as I do not see 3.6 there

Yes, you have posted in Arducopter V3.6 which is quite old. And Live Calibration is old too.

Could you tell me what should I do?
As of now I realise my Mac does not support the latest APM planner 2 and have called for a windows laptop.

You think that could sort the flips?

I’ll download the latest mission planner (for windows and update the firmware and follow all the process to get the drone calibration done, do you have any link to a youtube video which could help me with the process?

I changed the frame also thinkkng it could be a issue with the balance.

I use the APM 2.8. I do not have a gps and compass. This was just a basic build. I plan to sort the basic build first and then upgrade to the add ons like gps, fpv camera, telematry and a GoPro

Forget what I said. That Flight Controller hasn’t been supported in Ardupilot for years, it’s obsolete. You should be posting in the Copter 3.2 thread (moved it for you).

Get a new Fligt Controller that’s supported by current Ardupilot. There are many.

This is the flight controller by Ardu Pilot only. And is one of the most famous flight controller here used in india.

It’s still obsolete. Support for it ended in April of 2015…

Any solution, I have spend alot of money on this already and won’t want to put in any more money before I see it atleast fly for once.

I have seen people still using this set up

This is almost always due to the wrong motor order or direction.

Checked the motor order, the direction.
The properllers direction

Just to update you. 2.8 is not the firmware.

Ardupilot 2.8 is the model of the flight controller

I know that. 5 years ago I had several APM 2.6’s and 2.8’s. Just to update you the last Arducopter firmware to run on those boards is 3.2.1. Today we are at 4.0.7

Let’s check the basic stuff:

  • Any motor going to maximum? Check logs or post here
  • Props not upside down or CW on CCW motor?
  • Esc’s calibrated?
  • No trims on transmitter?

Have you checked servo output tab on setup. Did you recognize any uneven output on the servos even the quad is on its nees and propellers not attached. Applying throttle above %50 makes servo outputs different on each motor? This means there is a bug with arducopter 3.x and above with apm 2.8. Since I have the same issue out there. I will use previous versions for example arducopter 2.6. Then will update here.

There is no bug. Countless people flew APM’s with 3.2.1 w/o a problem. I had several, all thrown away now.

Actually I take that back. I do still have an APM with 3.2.1 that still fly’s. It just collects dust…