Flip on take-off after temporary down-rev to Copter 3.2

Hey everyone,

I’m hoping that I can call on the community to help me with a sanity check. While it might be more appropriate to post in the 3.2 section, I’m hoping that I can get a little more traction here.

I’ve been troubleshooting a very difficult pitch-axis twitching/oscillation problem. I’ve been running Copter 3.4.6 on a TBS Disco Pro for a few weeks now. The aircraft was twitchy, but flyable. In an effort to get the aircraft back to a point where it flew well, I re-flashed Copter 3.2. As a part of the re-flash process I first flashed Rover to wipe the EEPROM. I made no hardware changes. I didn’t unplug any cables, other than to re-calibrate the ESCs. I’m confident that I got the ESCs reconnected properly as I have the connectors numbered to match the Pixhawk PWM outputs. Just to be sure, I also verified ESC connection with MP Motor Test. I’ve triple-checked that the props are on correctly and spinning in the correct direction. I repeated all setup and calibration steps. I verified that the accelerometers are properly calibrated by observing the aircraft’s attitude in the Mission Planner HUD, while moving it around by hand.

As far as I can tell, everything is groovy, but when I try to take off, the aircraft immediately wants to flip to the left and then spin on the Yaw-axis. I’ve never before seen this behavior in any of my quads. I can hear the right side props spin up much harder than the left two. The log shows some crazy attitude stuff going on. Desired Roll goes to 22 and stays there as soon as I touch the throttle. As the aircraft just starts to lift off, Desire Yaw and Yaw oscillate in a weird sawtooth. I’ve looked at the RC Inputs for Roll and Pitch. They are centered. There is a Mag reading that parallels the Yaw oscillation. I’m not sure what that’s about. I haven’t had any Mag issues with this platform before.

For reference, the ESCs in use are Turnigy, Multistar V2, Slim, with BLHeli firmware.

I’ve attached a screenshot of the readings I’m talking about. I don’t want to link the whole log, as it contains the GPS coordinates of my home. However I can quickly respond to requests for other screenshots.

I consider it to be entirely possible that I’m missing something. It happens often enough. I would sincerely appreciate any advice. I won’t be offended if you tell me “Hey dummy, check…”.




Not sure if this will help, but I upgraded from 3.3.3 to 3.4.6 recently and when I brought the baby up on 3.4.6 it was not flyable at all, like really really crazy instable.

In the end I figured out that the root cause was that PID scales or something related to that had signficantly changed from 3.3.3 to 3.4.6, so the PID values that worked very well on 3.3.3 led to near crashin 3…4.6 - it was so bad I couldn’t even do an autotune.

I resolved my issue by loading some iris default values for PID. The result was bad too, but good enough for me to run a scary autotune session after which things are good again.

Long story short - maybe the PID values you entered after the downgrade are “bad” and lead to this? Did you put in the values from 3.4.6?


Hi Chris,

Thanks for the suggestion.

I also encountered the issue you describe when going from 3.3.3 to 3.4.6. However, in this case, I left the 3.2 default PIDs intact. I tried to enter my PIDs from 3.4.6, but apparently they are out of range. So right now, I still have default 3.2 PID gains.



This issue has become irrelevant. I couldn’t get the copter to take off. I went back to 3.4.6 and it takes off just fine. No idea what the problem is.